Bug 3022 - Filters/Pre/Post Processing completely broken
Summary: Filters/Pre/Post Processing completely broken
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Filtering (show other bugs)
Version: 3.9.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 3051 3087 3118 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-21 19:45 CEST by Stephen
Modified: 2014-03-22 14:19 CET (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen 2013-10-21 19:45:39 CEST
First:
 -  Imported 4 t-bird filters via provided script - don't work - period!
Second:
 -  Create new filter - completely broken.
Steps:
 - Open Claws
 - Select INBOX (why not selected initially, Woosh. . . .)
 - Configuration->Filtering
 -  Click on NAME box - add name
 -  Click on Account - Select specific account (only 1 defined)
 -  Click in Condition box - gets highlightes (i.e. border)
 -  Click Define button
 -  Get Condition Configuration Dialog box
 -  Match Criteria:  Select Header from Drop down box - get additional fields to fill in.  Set Name to From -- contains "name"
 -  Click "Add" button, now shows up in lower box.
 -  Click on this rule to get "OK" button to highlight
 -  Click "OK" - goes back to filtering Configuration w/condition 
 -  Click on Action dialog box - gets highlighted (border), OK button goes Active.  
 -  Click on Define Button, get Action configuration dialog box.
==> AT this point, I'm hosed - this dialog box is non-functional, and there's NO way to exit/cancel out of it.  The "X" button will "click" when clicked, but the dialog box remains. 
 -  if I go back to the Filtering configuration dialog box, and try to exit that (via cancel or close button) - I get another dialog box indicating that Editing is occuring, do I wish to continue or cancel.  This box also becomes non-functional, cannot exit/close it.
  Only way out is to KILL the entire program.  

 -  Please address this ASAP - Thanks in advance for your efforts.
Comment 1 Paul 2013-10-21 22:07:43 CEST
What script did you use? Can you send me your ~/.claws-mail/matcherrc file and the thunderbird filters file privately, please?
Comment 2 Ricardo Mones 2013-10-22 09:32:25 CEST
Regarding the Action configuration dialog box it works fine here (git version).

Can you reproduce that with latest release 3.9.2 ?

Also, which window manager are you using?
Comment 3 Paul 2013-10-22 09:41:27 CEST
The problems with the filtering dialogue sound a lot like bug #2933, which are caused by the overlay-scrollbar-gtk2 package, and nothing to do with the apparent symptoms. If you have this package installed, remove it, it breaks things. See https://bugs.launchpad.net/ubuntu/+source/overlay-scrollbar/+bug/903302
Comment 4 Stephen 2013-10-22 22:42:01 CEST
NOTE:  I am not a linux expert, I do "embedded" linux development for a living, which is very different.
RE: testing in 3.9.2 - this will not build in my system:
stephen@Stephen-B-Computer:/usr/lib$ ls -l *etpan*
lrwxrwxrwx 1 root root     18 Oct 19  2011 libetpan.so.15 -> libetpan.so.15.0.0
-rw-r--r-- 1 root root 688880 Oct 19  2011 libetpan.so.15.0.0

checking for libetpan-config... no
*** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/ 
*** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.
configure: error: libetpan 0.57 not found
stephen@Stephen-B-Computer:/tmp/claws-mail-3.9.2$ 
 -  I have to be careful what gets put on this system so as not to disburb the existing setup.  

RE: Window Manager - beats me - Ubuntu 12.04LTS - gnome??  (NOT Unity)

RE: Previous Bug #903302:
 -  Do NOT have this library installed on this system.

Regards,
Stephen Beckwith
Comment 5 Paul 2013-10-23 09:41:59 CEST
Hi Stephen,

Thanks for sending matcherrc privately.

This has nothing to do with the conversion script. There is nothing wrong with your matcherrc file at all.

Please run this command and tell us the output, if any:

dpkg -l | grep overlay-scrollbar

For you problem with building Claws Mail from source, you need the libetpan-dev package.
Comment 6 Stephen 2013-10-23 14:14:24 CEST
Paul,
  Well. . . "Old dog learns new trick" :)  Guess I actually DO have the "troublesome" libraries:
stephen@Stephen-B-Computer:~$ dpkg -l | grep overlay-scrollbar
ii  liboverlay-scrollbar-0.2-0             0.2.16-0ubuntu1.1                                   Scrollbar overlayed widget - shared lib
ii  liboverlay-scrollbar3-0.2-0            0.2.16-0ubuntu1.1                                   Scrollbar overlayed widget - shared lib
ii  overlay-scrollbar                      0.2.16-0ubuntu1.1                                   Scrollbar overlayed widget
 -  used apt-get remove the 2 libs.
 - I used apt-get remove to remove these 2 libraries, then I reset my system.
I am glad to report that I was successful in adding a new filter without any problems.  Thank You!

 - Now. .   Lets see if the new filter actually worked. (may take a while)
The Imported Filters DID NOT work this morning - Messages that "should" have been filtered were in my inbox this morning. . . .

I'll keep you posted.
Thanks Again!
Regards,
Stephen Beckwith
Comment 7 Paul 2013-10-23 14:39:32 CEST
actually "INVALID" because it's not our bug.

Glad you got it sorted!
Comment 8 Paul 2014-01-08 08:41:17 CET
*** Bug 3051 has been marked as a duplicate of this bug. ***
Comment 9 Paul 2014-02-09 09:48:48 CET
*** Bug 3087 has been marked as a duplicate of this bug. ***
Comment 10 Paul 2014-03-22 14:19:05 CET
*** Bug 3118 has been marked as a duplicate of this bug. ***