Bug 2933 - the window manager looses a popup window
Summary: the window manager looses a popup window
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.9.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 2694 2920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-04 16:40 CEST by Sylvain BERTRAND
Modified: 2013-06-30 13:11 CEST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain BERTRAND 2013-06-04 16:40:04 CEST
On GNU/Linux Debian ubuntu 13.04 (32bits or 64bits), using the official 3.8.1 claws mail or the  PPA 3.9.1 claws mail, the window managers (gnome 3 or unity or openbox(lxde)) do loose some popup windows. Have to kill the application.

To reproduce, try to configure a filter, you should "loose" a popup in the process, the popup is unresponsive and you are then stuck. It did happen for several different popups.
Comment 1 Paul 2013-06-10 08:36:20 CEST
re-opened because I modified the wrong bug report!!
Comment 2 Paul 2013-06-10 09:04:47 CEST
Tried with lxde and Claws 3.9.2 and it works fine for me.

I suspect that, if anything, it's mishandling of modal windows in unity, and that rather than losing a window it's actually a modal window that wrongly goes behind another window, thus making the presented window appear to be unresponsive.
Comment 3 Sylvain BERTRAND 2013-06-10 12:46:45 CEST
This is not specific to unity. As I wrote down, it seems all window managers are affected. What I forgot to write down, sylpheed (the "other one") is affected by the same bug (evolution is not).
Comment 4 Paul 2013-06-10 12:53:14 CEST
I saw what you wrote but, nevertheless, not all window managers are affected. Of the 3 you listed, I tried lxde and could not reproduce the problem.
Comment 5 Paul 2013-06-10 12:54:19 CEST
evolution is gtk3. sylpheed, like claws-mail is gtk2.
Comment 6 Sylvain BERTRAND 2013-06-10 12:57:03 CEST
Then it would be GNU/Linux Debian Ubuntu specific, with high suspicion on their gtk2 build.
Comment 7 Paul 2013-06-10 13:10:58 CEST
This report could be relevant:
https://bugs.launchpad.net/ubuntu/+source/overlay-scrollbar/+bug/903302

Do you have the overlay-scrollbar packages installed?
Comment 8 Sylvain BERTRAND 2013-06-10 13:35:56 CEST
Tested: popup windows now responsive after full overlay-gtk removal.

Great work!

moving the bug to proper faulty components.
Comment 9 Paul 2013-06-30 13:09:17 CEST
*** Bug 2920 has been marked as a duplicate of this bug. ***
Comment 10 Paul 2013-06-30 13:11:04 CEST
*** Bug 2694 has been marked as a duplicate of this bug. ***