Bug 3051 - Popup windows not getting focus. Unable to create Actions, Processing or filtering rules.
Summary: Popup windows not getting focus. Unable to create Actions, Processing or filt...
Status: RESOLVED DUPLICATE of bug 3022
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.9.3
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2014-01-08 03:50 CET by Ru
Modified: 2014-01-08 08:41 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ru 2014-01-08 03:50:20 CET
I have just started using Claws and I am also finding this window focus bug in multiple situations as follows:
Menu Item-> Configuration->Actions->Edit Filter Action == The Edit Filter Actions window does not get focus. So you can't create a filter action.
Menu Item-> Configuration->Filtering->Define Actions == The Define Actions window does not get focus. So you can't create an action.
The above is the same for all three processing configuration options. This includes if they are opened from a folder right click or the main menu.

Effectively I am unable to create any Filter / Actions / Processing Rules.

I was originally on 3.8.1, I have just upgraded to 3.9.3 but the issue still exists.

I'm on Ubuntu 12.04 with lightdm and the XFCE window manager.
Comment 1 Paul 2014-01-08 08:41:17 CET
This is because of the bugged-out overlay-scrollbar packages. It has been reported many times, but the overlay-scrollbar developers do not appear to want to fix it.

The solution for your problem in Claws is to remove all overlay-scrollbar* packages from your system.

*** This bug has been marked as a duplicate of bug 3022 ***