Bug 3644 - Fancy renders blank page for most html emails when using shared-mime-info 1.6
Summary: Fancy renders blank page for most html emails when using shared-mime-info 1.6
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.13.2
Hardware: PC Linux
: P3 major
Assignee: users
URL:
: 3649 3713 3776 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-05 20:15 CEST by Bryan Gilbert
Modified: 2017-06-17 17:15 CEST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bryan Gilbert 2016-05-05 20:15:12 CEST
Using shared-mime-info 1.6 on my system (Arch Linux - https://www.archlinux.org/packages/extra/x86_64/shared-mime-info/) results in a majority of emails rendering blank pages when viewing in html. Downgrading to shared-mime-info 1.5 resolves the issue completely with all emails displaying properly.

I've not yet discovered a correlation between the emails that display correctly and the ones that result in blank screens. I will report back if I am able to do so.

Additionally, here is a link to the forum thread with others experiencing the same issue:

https://bbs.archlinux.org/viewtopic.php?id=211484

Thank You.
Comment 1 Paul 2016-05-05 22:04:33 CEST
Using share-mime-info 1.6 on a fedora system and every html mail displays fine with the Fancy plugin. Looks like some other problem on arch.
Comment 2 Paul 2016-05-05 22:38:18 CEST
Bryan, you probably should look in the direction of webkit, which is what the Fancy plugin uses, rather than Claws Mail.
Comment 3 Bryan Gilbert 2016-05-06 00:30:30 CEST
Thanks for the pointer and for taking the time to look at the issue!
Comment 4 Paul 2016-05-27 15:24:01 CEST
*** Bug 3649 has been marked as a duplicate of this bug. ***
Comment 5 Martin Schwenke 2016-06-14 06:36:18 CEST
I understand that this is closed, but people come here looking for
answers to this and I just found one, so I figure it is worth
documenting what I found to try and help others...  :-)

When using the Fancy plugin files like this are created:

  ~/.claws-mail/mimetmp/000000c0.mimetmp.html

Note the ".html" extension.

By bisecting my configuration, I found I had a file called:

  ~/.local/share/mime/packages/user-extension-html.xml

containing:

  <?xml version="1.0" encoding="UTF-8"?>
  <mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
   <mime-type type="application/x-extension-html">
    <comment>html document</comment>
    <glob pattern="*.html"/>
   </mime-type>
  </mime-info>

This looks like it maps files with extension .html to MIME type
application/x-extension-html.

Removing this file and running:

  update-mime-database ~/.local/share/mime

stopped the problem with the Fancy plugin occurring.

Note that running the above command makes other changes to
~/.local/share/mime/ so you might want to backup this directory when
testing.

If I re-add the file and run the above command again the problem
returns.

Another thing that works around the problem is removing the changes to
/usr/share/mime/packages/freedesktop.org.xml mentioned at
https://bbs.archlinux.org/viewtopic.php?pid=1623743#p1623743, which
seems to explain why downgrading shared-mime-info helps.

I'm not sure what created
~/.local/share/mime/packages/user-extension-html.xml.  However,
neither it nor most of the other contents of ~/.local/share/mime/ had
changed for over a year (probably since I installed this new laptop
and started using it).  However, when I upgraded shared-mime-info to
1.6 back in early May, this triggered a bug somewhere in combination
with the existence of this file.  I wish I understood more...
Comment 6 Paul 2016-10-24 10:53:37 CEST
*** Bug 3713 has been marked as a duplicate of this bug. ***
Comment 7 Paul 2017-03-01 00:33:40 CET
*** Bug 3776 has been marked as a duplicate of this bug. ***
Comment 8 Martin Nicholas 2017-03-01 12:59:24 CET
So the solution would be either: not to use the ".html" extension, use an appropriate extension or to force the mimetype onto the plugin.

Of the three files in my ~/.claws-mail/mimetmp/, two are xhtml and the other is rough html with no DTD.
Comment 9 Paul 2017-03-01 13:04:36 CET
No. According to the arch bug item the solution is to remove
~/.local/share/mime/packages/user-extension-html.xml

and then run

update-mime-database ~/.local/share/mime
Comment 10 Martin Nicholas 2017-04-24 14:17:45 CEST
Yep, Fiddling with mime types does indeed nullify the effect of this bug. This is achieved at the expense of another (unknown) program which is now broken in some way. 

Furthermore, under certain circumstances a link in an HTML mail such as:
<a href="#top">To the top</a>
opens this temporary file in the default (?) browser, rather than the required behaviour of scrolling to the top.

A typical user will regard both these behaviours as bugs. Hint: There are no typical users reading this thread.
Comment 11 Colin Leroy 2017-06-17 17:15:17 CEST
Oh, 
This is probably fixed by commit b320c5095cd51213520d8011ae4969e97c8f7436 :)