Bug 3338 - Claws Mail 3.11.1-34 core dumps if RSSyl is loaded
Summary: Claws Mail 3.11.1-34 core dumps if RSSyl is loaded
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/RSSyl (show other bugs)
Version: 3.12.0
Hardware: PC FreeBSD
: P3 critical
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2014-11-27 15:40 CET by Michael Hughes
Modified: 2014-12-07 23:34 CET (History)
0 users

See Also:


Attachments
gdb thread apply all bt output (6.73 KB, text/plain)
2014-11-27 15:40 CET, Michael Hughes
no flags Details
debug output (8.21 KB, text/plain)
2014-11-29 15:09 CET, Michael Hughes
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hughes 2014-11-27 15:40:51 CET
Created attachment 1452 [details]
gdb thread apply all bt output

I have been having some problems with Claws Mail the last couple weeks core dumping when RSSyl is loaded.  I first noticed it when I would come back to my workstation and Claws Mail wouldn't be running.  I have also had Claws Mail core dump right after starting.
Comment 1 Michael Hughes 2014-11-27 15:42:30 CET
FreeBSD 8.4-RELEASE-p18 

Claws Mail version 3.11.1git34
runtime GTK+ 2.24.22 / GLib 2.36.3
buildtime GTK+ 2.24.22 / GLib 2.36.3
Compiled-in features:
 Enchant
 GnuTLS
 IPv6
 iconv
 LDAP
 libetpan 1.1
 libSM
Comment 2 Ricardo Mones 2014-11-27 16:45:07 CET
(In reply to comment #1)
> FreeBSD 8.4-RELEASE-p18 
> 
> Claws Mail version 3.11.1git34
> runtime GTK+ 2.24.22 / GLib 2.36.3
> buildtime GTK+ 2.24.22 / GLib 2.36.3
> Compiled-in features:
>  Enchant
>  GnuTLS
>  IPv6
>  iconv
>  LDAP
>  libetpan 1.1
>  libSM

Is it 32 bit or 64 bit?
Comment 3 Andrej Kacian 2014-11-27 21:09:25 CET
Michael, does the crash always happen during update of the same feed, or is it random?
Comment 4 Michael Hughes 2014-11-27 23:48:52 CET
This is a 64 bit system.

I'm not sure if it is the same feed or not.  Is there an easy way to figure this out?
Comment 5 Michael Hughes 2014-11-28 00:02:22 CET
I just refreshed the feeds I have one at a time and it seems to always core dump on two of the feeds each time I try to refresh them.  One of the feeds is the Claws Mail GIT feed (http://git.claws-mail.org/?p=claws.git;a=rss)
Comment 6 Michael Hughes 2014-11-29 15:09:11 CET
Created attachment 1453 [details]
debug output

This is the debug output of the RSSyl plugin.  I started Claws Mail and the selected Refresh feed for the git.clawsa-mail.org feed.
Comment 7 Michael Hughes 2014-11-29 15:54:34 CET
I have found that the → in the title of the git feed is causing the core dump.  I added the character to the title of one of my post and it core dumped.
Comment 8 Michael Hughes 2014-12-05 01:00:36 CET
Is there anything else that I can do to help fix this problem?
Comment 9 Andrej Kacian 2014-12-07 15:58:21 CET
Well, I am at a loss here, since I can not reproduce the crash on Linux, and I can't find the time to install and configure a FreeBSD VM to test in.
Comment 10 users 2014-12-07 23:34:03 CET
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2014-12-07 23:34:02.964456812 +0100
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=9a22e2e2c1f109da612228462e4552fb5ba2e9ff
Merge: 70bd331 1ffe0d0
Author: Colin Leroy <colin@colino.net>
Date:   Sun Dec 7 23:34:02 2014 +0100

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=1ffe0d0d1a4433fd841d282a9a65161044b08e21
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Sun Dec 7 23:31:41 2014 +0100

    Properly allocate buffer in conv_encode_header_full() for quoted-printable encoding. Closes bug #3338, reported by Michael Hughes.
Comment 11 Andrej Kacian 2014-12-07 23:34:56 CET
This has been fixed in commit 1ffe0d0. Thank you, Michael, for off-list testing!
Comment 12 users 2014-12-07 23:45:00 CET
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2014-12-07 23:44:02.675807118 +0100
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=9a22e2e2c1f109da612228462e4552fb5ba2e9ff
Merge: 70bd331 1ffe0d0
Author: Colin Leroy <colin@colino.net>
Date:   Sun Dec 7 23:34:02 2014 +0100

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=1ffe0d0d1a4433fd841d282a9a65161044b08e21
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Sun Dec 7 23:31:41 2014 +0100

    Properly allocate buffer in conv_encode_header_full() for quoted-printable encoding. Closes bug #3338, reported by Michael Hughes.

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=70bd33140aa5e61e2feb8a17683d8672d92f0767
Merge: d4531ca e746281
Author: Colin Leroy <colin@colino.net>
Date:   Sun Dec 7 22:35:02 2014 +0100

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=e746281f5fd9a7678550c29c5618f67c50ee055b
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Sun Dec 7 22:33:26 2014 +0100

    Compose window: activating the GtkEntry with sender address activates the account selection combobox. Closes bug #3345, reported by  Barry Warsaw.