Bug 4022 - Closing "Account Preferences" window opens "Edit Accounts" window from cache
Summary: Closing "Account Preferences" window opens "Edit Accounts" window from cache
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.14.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2018-05-04 06:19 CEST by Avinash Sonawane
Modified: 2018-05-04 09:45 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Avinash Sonawane 2018-05-04 06:19:25 CEST
Hello!

Steps to reproduce the bug:

1. Fresh open claws-mail
2. Now open "Account preferences" window (Configuration > Preferences for current account)
3. Now close the "Account preferences" window

You'll see no other window popping up. Totally expected UI behavior.

4. Now, open "Edit accounts" window (Configuration > Edit Accounts)
5. Close the "Edit accounts" window
6. And now open the "Account preferences" window (Configuration > Preferences for current account)

You'll see "Edit accounts" window popping up automatically. I think this is because "Edit accounts" window is in cache (that's good for speed) but why to invoke the "Edit accounts" window from cache when "Account preferences" window is closed?

This is not at all expected UI behavior.
Comment 1 Avinash Sonawane 2018-05-04 06:26:12 CEST
Sorry, forgot step 7.

> 6. And now open the "Account preferences" window (Configuration > Preferences for current account)

7. Close the "Account preferences" window
Comment 2 users 2018-05-04 09:05:06 CEST
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2018-05-04 09:05:05.549931109 +0200
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=f84e6614ffc8255485897fe12c79311085d8d02f
Merge: e4848f3 e5a0593
Author: Colin Leroy <colin@colino.net>
Date:   Fri May 4 09:05:03 2018 +0200

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=e5a059330156212c1d83eb5e4af86a66a103df7d
Author: wwp <wwp@free.fr>
Date:   Fri May 4 09:04:04 2018 +0200

    Don't manage account list focus state when closing an account edit window,
    when this window has been called from main window's "Preferences for
    current account" menu item.
    Closes bug #4022: Closing "Account Preferences" window opens "Edit Accounts"
    window if "Edit Accounts" window has been opened before at least once.