Bug 3950 - marks all emails as "read"
Summary: marks all emails as "read"
Status: NEW
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.15.0
Hardware: PC Windows 7
: P3 normal
Assignee: users
URL:
: 3961 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-17 23:00 CET by wazz
Modified: 2018-02-14 00:00 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wazz 2018-01-17 23:00:22 CET
Every now and then Claws marks all my emails in my main folder as "read".  It has happened with prior versions, and now with the 64bit version.
Comment 1 Paul 2018-02-11 17:54:43 CET
*** Bug 3961 has been marked as a duplicate of this bug. ***
Comment 2 Andrej Kacian 2018-02-13 17:44:56 CET
Do you have automatic mail checking enabled?
Do you use any filters in Claws Mail?
Is this on an IMAP account, or POP3 with a local (MH) mailbox?

The only way I see this could happen is that somehow, in all folders of the local mailbox, the .claws_mark file gets deleted. That is the file holding info about message flags, including "new" and "unread" flags.
Comment 3 wazz 2018-02-13 18:12:13 CET
IMAP, no filters, no auto check
Comment 4 Shai Berger 2018-02-13 23:00:58 CET
(In reply to comment #2)
> 
> The only way I see this could happen is that somehow, in all folders of the
> local mailbox, the .claws_mark file gets deleted. That is the file holding
> info about message flags, including "new" and "unread" flags.

Actually, in my experience, a folder where the .claws_mark file is missing gets all marked unread, not all read.

Bug reporter: Do you also access the IMAP account from some other client simultaneously?
Comment 5 wazz 2018-02-14 00:00:52 CET
No, never simultaneously.