Bug 3895 - Port from libnm-util/libnm-glib to libnm (or GNetworkMonitor)
Summary: Port from libnm-util/libnm-glib to libnm (or GNetworkMonitor)
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.16.0
Hardware: All All
: P3 enhancement
Assignee: users
URL:
: 3938 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-07 20:34 CEST by Ricardo Mones
Modified: 2018-05-17 01:16 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo Mones 2017-09-07 20:34:55 CEST
Seems the quest for deprecation of everything continues... :)

The request starts as follows (in this excerpt the word "package"
is read like "Claws Mail"):
[…]
> the libnm-glib/libnm-util libraries have been deprecated upstream in
> favour of libnm.
> 
> Your package declares a Build-Depends on network-manager-dev.
> 
> It seems to not actually link against libnm-util/libnm-glib, but uses
> the D-Bus API for the online connectivity check and requires a few
> macros and defines from NetworkManager.h.
> 
> Please consider porting claws-mail to libnm. The API of libnm is very
> similar to the one provided by libnm-glib/libnm-util [1], e.g. the
> NetworkManager.h header file is also provided by libnm.
[…]

Full details and a patch with explanation for one of the alternatives
on Debian's bug: https://bugs.debian.org/862879

best regards,
Comment 1 Ricardo Mones 2017-12-20 13:45:52 CET
*** Bug 3938 has been marked as a duplicate of this bug. ***
Comment 2 Ricardo Mones 2018-05-04 19:40:21 CEST
Just received this:
----------------------------------------
Date: Fri, 04 May 2018 04:39:06 +0000
From: Debian testing autoremoval watch <noreply@release.debian.org>
To: claws-mail@packages.debian.org
Subject: claws-mail is marked for autoremoval from testing

claws-mail 3.16.0-1 is marked for autoremoval from testing on 2018-05-15

It is affected by these RC bugs:
862879: claws-mail: Port from libnm-util/libnm-glib to libnm (or GNetworkMonitor)
----------------------------------------

So, I'm wondering if is the patch attached to the Debian bug good enough or does it need something more?
Comment 3 Ricardo Mones 2018-05-04 19:50:06 CEST
Was going to add it, but patch itself was also forwarded to bug #3938 in case you want to see it ;-)
Comment 4 Michael Schwendt 2018-05-05 14:28:47 CEST
> https://bugzilla.redhat.com/show_bug.cgi?id=1530613#c2

The patch misses a second NM_CHECK_VERSION that needs to be removed, too, or else the code would fail.

https://src.fedoraproject.org/rpms/claws-mail/blob/master/f/claws-mail-3.16.0-libnm.patch
Comment 5 Ricardo Mones 2018-05-06 11:56:41 CEST
(In reply to comment #4)
> > https://bugzilla.redhat.com/show_bug.cgi?id=1530613#c2
> 
> The patch misses a second NM_CHECK_VERSION that needs to be removed, too, or
> else the code would fail.
> 
> https://src.fedoraproject.org/rpms/claws-mail/blob/master/f/claws-mail-3.16.
> 0-libnm.patch

Many thanks Michael! Your patch builds fine here in Debian stable, so I'll use it to patch the Debian package and avoid its removal from testing.

Unless anybody has any objection I think I'll push it to master soon (hopefully during this week).
Comment 6 users 2018-05-17 00:08:09 CEST
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2018-05-17 00:08:08.833170291 +0200
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=b17945773f0ebcd8ddb90b7ba5d09b9d80084a56
Merge: cf682cc dee4e69
Author: Colin Leroy <colin@colino.net>
Date:   Thu May 17 00:08:05 2018 +0200

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=dee4e692b4a8574841d4f26222098ee52944de01
Author: Michael Schwendt <mschwendt@fedoraproject.org>
Date:   Tue Mar 13 21:03:46 2018 +0100

    Fix bug 3895: Port from libnm-util/libnm-glib to libnm