Bug 3639 - Client stops checking email automatically after 1 connection error
Summary: Client stops checking email automatically after 1 connection error
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: POP3 (show other bugs)
Version: other
Hardware: PC Linux
: P3 blocker
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2016-04-12 21:15 CEST by some random user
Modified: 2016-04-16 21:00 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description some random user 2016-04-12 21:15:15 CEST
Connection is unstable here, so sometimes I will go offline..
so when it automatically checks the email, I will get an error saying 

> ERROR
> Connection to mail.server.com:110 timed out.

after that if the internet is back, it will never check my email again, until I hit OK in the dialog of the connection error.
which makes the client unreliable, because i need to be constantly checking if there is an error message in order to make sure no new mail has arrived.

I think if the internet is back and it its time to automatically check again and the dialog is open, it should even close it since it's outdated information and user doesn't need to know that there was a connection error before.

thank you
Comment 1 Charles A Edwards 2016-04-12 21:58:39 CEST
This is not a bug.
The option can be set|unset by user.

Under Configuration/Receiving check the box
"Don't popup error dialog on receive error."
and the error dialog will will no longer be used.

Charles
Comment 2 Paul 2016-04-12 22:01:08 CEST
Additionally you can use NetworkManager support to handle online/offline states.
Comment 3 some random user 2016-04-13 04:17:09 CEST
thanks for the tip about disabling the notification.
Still, I think the client under no circumstances should stop checking my mail every X minutes. While the notification is there, 
it still should be checking my mail in the background

sorry, but I cannot seem to find the NetworkManage option

thanks for the fast response
Comment 4 some random user 2016-04-14 23:00:53 CEST
I'm reopening as no awswer has been given to my last comment
Comment 5 Paul 2016-04-15 09:36:12 CEST
This is not a chat forum. I'm not sure what you thought you needed a response to. If it was your NetworkManager statement, this is a compile time option. If you want to ask question please use the channels detailed here: http://www.claws-mail.org/MLs.php
Comment 6 some random user 2016-04-16 06:44:18 CEST
well... comments are enabled for back and forth communication.


so ...if you think that your mail client should get BLOCKED and  stop checking the mail because you haven't accepted the error message, and you haven't changed your non-default setting....
so if you think there's nothing wrong with that..
then, i don't think there's much point to talk it about in the mailing list.
Comment 7 Paul 2016-04-16 09:58:07 CEST
(In reply to comment #6)
> well... comments are enabled for back and forth communication.
> 
> 
> so ...if you think that your mail client should get BLOCKED and  stop
> checking the mail because you haven't accepted the error message, and you
> haven't changed your non-default setting....

You saw that this got RESOLVED as INVALID....
Comment 8 some random user 2016-04-16 21:00:17 CEST
still you don't provide a reasonable answer while the mail client should be blocked, just because you forgot to change a default setting.

It's like your washing machine asking for confirmation when for 5 minutes there was not enough water,and when you come back to get your laundry all you see is message saying "There's been an error and there was not running water at some point. Please press OK to confirm you want to check again for water"
and when you press OK, water starts pouring into the laundry machine.