Bug 3403 - Crashes on HTML (I think)
Summary: Crashes on HTML (I think)
Status: RESOLVED WORKSFORME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Message View (show other bugs)
Version: 3.10.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-03-18 14:57 CET by Michael Jordan
Modified: 2015-03-19 15:21 CET (History)
0 users

See Also:


Attachments
gdb backtrace (15.17 KB, text/plain)
2015-03-18 14:57 CET, Michael Jordan
no flags Details
Troublesome email (3.20 KB, text/plain)
2015-03-19 12:52 CET, Michael Jordan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Jordan 2015-03-18 14:57:09 CET
Created attachment 1498 [details]
gdb backtrace

Certain messages, whenever I click on them to view them, Claws crashes. Backtrace attached.
Comment 1 Paul 2015-03-18 15:47:27 CET
works for me. try with the latest release, re-open if it still happens
Comment 2 Michael Schwendt 2015-03-18 20:12:16 CET
Further comments:

* The backtrace is kinda strange. Which one is the crashed thread? Thread 13? That's very deep in the LabVIEW runtime library.

* Since you sound as if you can reproduce the issue with the HTML message(s) you refer to, can you make available such a message? e.g. attach it here unmodified?
Comment 3 Michael Jordan 2015-03-19 12:52:36 CET
Created attachment 1499 [details]
Troublesome email
Comment 4 Michael Jordan 2015-03-19 12:54:24 CET
This one seems fairly consistent. I'm running Ubuntu 14.10 with KDE frameworks 5.
Comment 5 Michael Schwendt 2015-03-19 13:11:11 CET
> This one seems fairly consistent.

Emphasis on "seems".  The attached message is not sufficient to crash Claws Mail 3.11.1 running on Fedora 21 (x86_64).
Comment 6 Michael Jordan 2015-03-19 13:35:46 CET
Well, your project, and you can do as you wish, but I just went back to double check, and click on message . . . crash *again*.
Comment 7 Paul 2015-03-19 13:58:29 CET
I've tested on ubuntu 14.10 and KDE 4.14.1 and don't get a crash.
Comment 8 Michael Schwendt 2015-03-19 15:21:02 CET
@Michael Jordan

I don't claim that it doesn't crash for you. I just point out that the attached mail is not a sufficient test-case for Claws Mail 3.11.1. That also implies that you may want to update and try to reproduce with that newer version, although there is no conclusion that only 3.10.1 would be affected.

You may need to do more trouble-shooting to collect data and find out what's wrong with your runtime environment (i.e. the dependencies you've built with). You have yet to reply to the first part of comment 2.

Btw, I'm not a Claws Mail developer.