Bug 2926 - Segfault with imap_threaded_noop
Summary: Segfault with imap_threaded_noop
Status: RESOLVED DUPLICATE of bug 3145
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders/IMAP (show other bugs)
Version: 3.9.2
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 2996 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-17 17:30 CEST by Richard Schwab
Modified: 2014-05-22 22:55 CEST (History)
2 users (show)

See Also:


Attachments
gdb log (with symbols) (12.06 KB, text/plain)
2013-05-17 17:30 CEST, Richard Schwab
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Schwab 2013-05-17 17:30:31 CEST
Created attachment 1265 [details]
gdb log (with symbols)

Hey there,

I'm using ge77b994 on Arch Linux x64.
gdb log is attached.
Comment 1 kardan 2013-07-31 08:47:45 CEST
claws should not crash on connection timeouts.

Program received signal SIGSEGV, Segmentation fault.
imap_threaded_noop (folder=0x87a8198, p_exists=p_exists@entry=0xbffff238, p_recent=p_recent@entry=0xbffff23c, p_expunge=p_expunge@entry=0xbffff240, p_unseen=p_unseen@entry=0xbffff244, p_uidnext=p_uidnext@entry=0xbffff248, p_uidval=p_uidval@entry=0xbfff
f24c) at imap-thread.c:1099
#0  imap_threaded_noop (folder=0x87a8198, p_exists=p_exists@entry=0xbffff238, p_recent=p_recent@entry=0xbffff23c, p_expunge=p_
expunge@entry=0xbffff240, p_unseen=p_unseen@entry=0xbffff244, p_uidnext=p_uidnext@entry=0xbffff248, p_uidval=p_uidval@entry=0xbffff24c) at imap-thread.c:1099
#1  0x080e10d3 in imap_cmd_noop (session=session@entry=0x883a420) at imap.c:4016
#2  0x080e16ae in imap_ping (data=0x883a420) at imap.c:559
#3  imap_ping (data=data@entry=0x883a420) at imap.c:547
#4  0xb740d087 in g_timeout_dispatch (source=source@entry=0x9366458, callback=0x80e1660 <imap_ping>, user_data=0x883a420) at /
build/glib2.0-EIRQgp/glib2.0-2.36.3/./glib/gmain.c:4413
#5  0xb740c333 in g_main_dispatch (context=0x84e66b0, context@entry=0x8721560) at /build/glib2.0-EIRQgp/glib2.0-2.36.3/./glib/
gmain.c:3054
Comment 2 Paul 2013-08-14 10:55:00 CEST
@Richard Schwab if you are still able to reproduce this problem then re-open with more info
Comment 3 Paul 2013-08-17 09:35:13 CEST
*** Bug 2996 has been marked as a duplicate of this bug. ***
Comment 4 Michael Schwendt 2013-08-27 10:47:26 CEST
Here's a fresh automated report with a backtrace from a Fedora 18 user:

  https://bugzilla.redhat.com/1001508
  |
  | Description of problem:
  | Claws-mail was running in the background. 

Backtrace: https://bugzilla.redhat.com/attachment.cgi?id=790822
Comment 5 Michael Schwendt 2013-11-19 22:52:04 CET
Somebody please reopen this ticket.

https://bugzilla.redhat.com/1032257
Backtrace: https://bugzilla.redhat.com/attachment.cgi?id=826275
Comment 6 Christopher Barry 2013-11-21 22:53:16 CET
I too am seeing this behavior using v3.9.2 on Debian AMD_64

It segfaults several times a day.

I have 2 IMAP accounts and a MH account defined.
Comment 7 Michael Schwendt 2014-01-26 14:02:11 CET
Another user reported:
|
| claws-mail has been minimized to the system tray and closed itself.
| set 2 on Imap mailboxes and 1 on pop3.
Comment 8 Colin Leroy 2014-05-22 22:55:54 CEST
Very probably dupe :)

*** This bug has been marked as a duplicate of bug 3145 ***