Bug 2909 - Changing folder quickly can cause wrong email to be deleted
Summary: Changing folder quickly can cause wrong email to be deleted
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.9.0
Hardware: PC Linux
: P3 blocker
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2013-04-15 16:55 CEST by Jan
Modified: 2013-04-16 17:43 CEST (History)
1 user (show)

See Also:


Attachments
freeze the summary before msg delete (1.00 KB, patch)
2013-04-15 17:55 CEST, Paul
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2013-04-15 16:55:43 CEST
After opening a folder I use shift-click to select a couple of messages, then I select "Delete..." from the right-click popup menu. Now a confirmation window pops up. When I click on "Delete" to confirm it and then quickly click on a different folder, that second folder will be opened and an email from that folder is delete and the originally selected messages remain untouched.

I guess this a racing condition and you might need a slow computer to reproduce. I lost emails due to this while something big like chromium was compiling in the background.
Comment 1 Paul 2013-04-15 17:24:17 CEST
how slow is your computer? what are its specs?
Comment 2 Paul 2013-04-15 17:55:52 CEST
Created attachment 1253 [details]
freeze the summary before msg delete

Can you try the attached patch and report back?
Comment 3 Jan 2013-04-15 20:06:58 CEST
Thank you for your very quick response and patch! I compiled claws-mail 3.9.0 with your patch and have not yet been able to reproduce the bug. Given the nature of the bug I cannot be entirely sure that it is gone but I got the impression that the patch successfully disabled the opportunity to change the folder while deleting the emails. I can test it during the next days and report back if you like.
Comment 4 Paul 2013-04-15 20:14:00 CEST
Yes, your impression is right. It should work fine .... in theory - I can't reproduce the bug, so you're in the best position for that.

Please do test and report back. Thanks!
Comment 5 Colin Leroy 2013-04-15 21:17:11 CEST
Patch looks good to me.
Comment 6 users 2013-04-16 10:51:07 CEST
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=6e07ee63b095bed0a715007327639c9e0a51c723
Author: Paul <paul@claws-mail.org>
Date:   Tue Apr 16 09:50:48 2013 +0100

    fix bug #2909, 'Changing folder quickly can cause wrong email to be deleted'
Comment 7 Jan 2013-04-16 17:43:38 CEST
I did some further testing and couldn't reproduce the bug anymore. So it looks to be fine now. Thank you again for the quick fix!