Bug 2740 - Claws hangs soon after it starts checking for Mail
Summary: Claws hangs soon after it starts checking for Mail
Status: RESOLVED DUPLICATE of bug 2546
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-09-30 16:47 CEST by Anja
Modified: 2012-10-06 08:08 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anja 2012-09-30 16:47:19 CEST
I open Claws-Mail, press button to check mail on all (a dozen) accounts, wait barely half a minute, then it happens. (in gdb it keeps printing forever the line "folder.c:2262:Removed message 2147483647 from cache.") Reinstalled to no avail.
Mint 13 xfce, Claws-Mail 3.8.0-1ubuntu1 with pgpinline, attach-warner, pgpmime, trayicon, archiver-plugin, attach-remover, perl-filter, vcalendar-plugin, address-keeper

(gdb) thread apply all bt

Thread 4 (Thread 0xb2a67b40 (LWP 2185)):
#0  0x00132416 in __kernel_vsyscall ()
#1  0x008d296b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00a74c74 in mailsem_internal_wait () from /usr/lib/libetpan.so.15
#3  0x00a74e7d in mailsem_down () from /usr/lib/libetpan.so.15
#4  0x082545cb in thread_run (data=0x87a0e28) at etpan-thread-manager.c:324
#5  0x008ced4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00cb7ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xb20ffb40 (LWP 2110)):
#0  0x00132416 in __kernel_vsyscall ()
#1  0x00ca9380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x00986a7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x009790ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0097956b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00fa01ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x0099c6b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x008ced4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x00cb7ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7fd48c0 (LWP 2098)):
#0  0x00132416 in __kernel_vsyscall ()
#1  0x00ca71fb in write () from /lib/i386-linux-gnu/libc.so.6
#2  0x00c3bb05 in _IO_file_write () from /lib/i386-linux-gnu/libc.so.6
#3  0x00c3b9e4 in ?? () from /lib/i386-linux-gnu/libc.so.6
#4  0x00c3d05e in _IO_do_write () from /lib/i386-linux-gnu/libc.so.6
#5  0x00c3d415 in _IO_file_overflow () from /lib/i386-linux-gnu/libc.so.6
#6  0x00c3c5a3 in _IO_file_xsputn () from /lib/i386-linux-gnu/libc.so.6
#7  0x00c31115 in fputs () from /lib/i386-linux-gnu/libc.so.6
#8  0x00980dfc in g_print () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0824a975 in debug_print_real (format=0x82bec34 "Removed message %d from cache.\n") at utils.c:3641
#10 0x081024bc in folder_item_scan_full (item=0x86e09b0, filtering=1) at folder.c:2262
#11 0x081054f7 in folder_item_scan (item=0x86e09b0) at folder.c:2498
#12 0x0811092a in folderview_check_new (folder=0x86dfa90) at folderview.c:1197
#13 0x0812e509 in inc_all_account_mail (mainwin=0x84a68e8, autocheck=0, notify=0) at inc.c:363
#14 0x0821ea1d in toolbar_inc_all_cb (widget=0x8461370, data=0x855b6b0) at toolbar.c:1073
#15 0x008f2243 in g_cclosure_marshal_VOID__VOIDv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#16 0x008f0727 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#17 0x00909a29 in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#18 0x0090a8af in g_signal_emit_by_name () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#19 0x00392420 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#20 0x008f2243 in g_cclosure_marshal_VOID__VOIDv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#21 0x008f0727 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#22 0x00909a29 in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#23 0x0090a453 in g_signal_emit () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#24 0x001ee21a in gtk_button_clicked () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#25 0x001ef630 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#26 0x008f2243 in g_cclosure_marshal_VOID__VOIDv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#27 0x008eedb7 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#28 0x008f0727 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#29 0x00909a29 in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#30 0x0090a453 in g_signal_emit () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#31 0x001ee13a in gtk_button_released () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#32 0x001ee184 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#33 0x002ad8a2 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#34 0x008ef2fd in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#35 0x008f0484 in g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#36 0x0090270d in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#37 0x00909ff5 in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#38 0x0090a453 in g_signal_emit () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#39 0x003e7413 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#40 0x002aba6e in gtk_propagate_event () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#41 0x002abe00 in gtk_main_do_event () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#42 0x00634758 in ?? () from /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
#43 0x00978d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#44 0x00979125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#45 0x0097956b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0x002aab8f in gtk_main () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#47 0x0807feb7 in main (argc=1, argv=0xbffffa64) at main.c:1653
Comment 1 Paul 2012-10-06 08:08:15 CEST
This seems to be a duplicate of bug #2546

*** This bug has been marked as a duplicate of bug 2546 ***