Bug 2717 - Starting new lines of reply within a "Paste as quotation" block results in wrong highlighting and no line wrap
Summary: Starting new lines of reply within a "Paste as quotation" block results in wr...
Status: REOPENED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Compose Window (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-08-02 15:45 CEST by Shlomi Fish
Modified: 2012-09-14 13:34 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shlomi Fish 2012-08-02 15:45:16 CEST
Hi all,

Thanks for Claws-Mail. It is a great mail user agent.

The claws-mail editor has many bugs with regards to handling line wrap and syntax highlighting properly, and this is one of them that I've encountered:

1. Copy this text to the copy buffer (without the [Q] and [/Q] delimiters):

[Q]
My Johnny is over the ocean.
My Johnny is over the sea.
My Johnny is foo bar.
Blackendon for the right time and the right moment.
[/Q]

2. Start composing a new message in claws-mail.

3. Select "Edit -> Special Paste -> "as quotation".

4. Type enter twice at the end of the first quoted line.

5. Type this line:

"Yet another compiler compiler for the black of the dawn and the lift of the sun and the morn of the cron and the question of the gone."

6. Result: the line will be highlighted the same as the quotation (in a blue colour here) and will not be line-wrapped, but a very long line. Instead it should be in black and line-wrapped.

Regards,

-- Shlomi Fish
Comment 1 Pierre Fortin 2012-08-02 16:03:13 CEST
Works as expected for me...  tried a) copying full lines and b) without the last newline.
Comment 2 Shlomi Fish 2012-08-02 16:31:07 CEST
I should note that I'm using claws-mail-3.8.0-3.mga2 on Mageia Linux 2 x86-64 . Pierre: what is your Claws-Mail version?
Comment 3 Pierre Fortin 2012-08-02 20:48:51 CEST
claws-mail-3.8.1cvs14 compiled on Mageia Linux 1 x86-64.
A few years ago, CM had weird, random wrapping issues; but those are all cleaned up now AFAIK.  I'd probably be the first to say "not again!" since I hunted for months to find a way to reproduce it back then...  :)
Comment 4 Shlomi Fish 2012-08-02 20:52:58 CEST
Pierre: let me try with your version that I will compile myself. Stay tuned.
Comment 5 Shlomi Fish 2012-08-02 21:21:54 CEST
Hi!

I can still reproduce it with claws-mail-3.8.1cvs24 compiled from source on Mageia Linux 2 x86-64 (with a remote X connection to a Mageia Linux 3/Cauldron x86-64 system):

shlomif@lap:~$ ldd ~/apps/claws-mail/bin/claws-mail 
        linux-vdso.so.1 =>  (0x00007fff2253d000)
        libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007fe5ac7f7000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fe5ac5a9000)
        libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007fe5abf7b000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007fe5abcc9000)
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007fe5abaa7000)
        libgio-2.0.so.0 => /lib64/libgio-2.0.so.0 (0x00007fe5ab75a000)
        libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007fe5ab556000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fe5ab34e000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007fe5ab124000)
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007fe5aaf18000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007fe5aacf8000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007fe5aaa48000)
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007fe5aa7fd000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fe5aa570000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007fe5aa33a000)
        libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007fe5aa0ec000)
        libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007fe5a9df8000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00007fe5a9be0000)
        liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2 (0x00007fe5a99d0000)
        libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2 (0x00007fe5a9782000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe5a9566000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fe5a92e4000)
        libetpan.so.16 => /usr/lib64/libetpan.so.16 (0x00007fe5a901d000)
        libgnutls.so.28 => /usr/lib64/libgnutls.so.28 (0x00007fe5a8d1f000)
        libdb-4.8.so => /usr/lib64/libdb-4.8.so (0x00007fe5a89a1000)
        libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fe5a8785000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fe5a83f9000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fe5a80bf000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007fe5a7eb8000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fe5a7ca6000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007fe5a7a9c000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007fe5a7899000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007fe5a7689000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007fe5a7480000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007fe5a7276000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007fe5a7073000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007fe5a6e70000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00007fe5a6c59000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fe5a6a41000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fe5a683d000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fe5ac9f9000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007fe5a65b5000)
        libdirectfb-1.5.so.0 => /usr/lib64/libdirectfb-1.5.so.0 (0x00007fe5a62da000)
        libdirect-1.5.so.0 => /usr/lib64/libdirect-1.5.so.0 (0x00007fe5a60b8000)
        libpng15.so.15 => /usr/lib64/libpng15.so.15 (0x00007fe5a5e6b000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fe5a5b0e000)
        libffi.so.5 => /usr/lib64/libffi.so.5 (0x00007fe5a5906000)
        libpcre.so.0 => /usr/lib64/libpcre.so.0 (0x00007fe5a56c8000)
        libssl.so.1.0.0 => /usr/lib64/libssl.so.1.0.0 (0x00007fe5a5468000)
        libcrypto.so.1.0.0 => /usr/lib64/libcrypto.so.1.0.0 (0x00007fe5a507c000)
        libtasn1.so.3 => /usr/lib64/libtasn1.so.3 (0x00007fe5a4e6b000)
        libnettle.so.4 => /usr/lib64/libnettle.so.4 (0x00007fe5a4c44000)
        libhogweed.so.2 => /usr/lib64/libhogweed.so.2 (0x00007fe5a4a31000)
        libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007fe5a47c3000)
        libp11-kit.so.0 => /usr/lib64/libp11-kit.so.0 (0x00007fe5a45b1000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fe5a4392000)
        libfusion-1.5.so.0 => /usr/lib64/libfusion-1.5.so.0 (0x00007fe5a4186000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fe5a3e86000)
        liblzma.so.5 => /usr/lib64/liblzma.so.5 (0x00007fe5a3c57000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fe5a3a53000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fe5a384d000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fe5a3638000)
Comment 6 Shlomi Fish 2012-08-02 21:32:37 CEST
OK, now I tried running ~/apps/claws-mail/bin/claws-mail (from the same build) on the Mageia 2 x86-64 laptop in a local X server (running video-radeon) and I got the same result - a long line coloured the same as a quotation.
Comment 7 Pierre Fortin 2012-08-03 02:00:05 CEST
just compiled 3.8.1cvs24 and still works fine here.
Since you included your ldd output, FWIW, I compared it to mine and here are the differences:
(not being a developer, I don't know why so many differences, or which might cause your problem.  I've been planning on moving to Mageia 2; but I'm not quite ready yet... maybe I should wait until your problem is solved :)

$ ldd /usr/local/bin/claws-mail
Mine (Mageia 1)                      Yours (Mageia 2)
libICE.so.6
libSM.so.6
libassuan.so.0 
libdbus-1.so.3 
libdbus-glib-1.so.2 
                                     libdirect-1.5.so.
                                     libdirectfb-1.5.so.0
libenchant.so.1
libetpan.so.15                       libetpan.so.16
                                     libffi.so.5
                                     libfusion-1.5.so.0
                                     libgcc_s.so.1
libgcrypt.so.11 
                                     libgmp.so.10
libgnutls.so.26                      libgnutls.so.28
libgpg-error.so.0 
libgpgme.so.11 
                                     libhogweed.so.2
                                     liblzma.so.5 
                                     libnettle.so.4 
                                     libp11-kit.so.0 
libpng12.so.0                        libpng15.so.15 
                                     libstdc++.so.6 
libstartup-notification-1.so.0 
libxcb-atom.so.1 
libxcb-aux.so.0 
libxcb-event.so.1
Comment 8 Paul 2012-08-03 07:36:10 CEST
cannot reproduce this with the latest release, 3.8.1. If you can reproduce this with version 3.8.1 then reopen this bug report. thanks.
Comment 9 Shlomi Fish 2012-08-03 15:31:06 CEST
> cannot reproduce this with the latest release, 3.8.1. If you can reproduce this
> with version 3.8.1 then reopen this bug report. thanks.

OK, an update: I now tried building 3.8.1 with ./configure --prefix="/opt/claws-mail", and while this bugs cannot be reproduced in a new UNIX user account (with an almost-empty Claws-Mail configuration), I can still reproduce it in my populated and tweaked account, with the same claws-mail-3.8.1 binary. I'll try to investigate further.
Comment 10 Shlomi Fish 2012-08-03 17:10:16 CEST
OK, after a long amount of investigation (and keep trying to look at the wrong file) I realised that the problem with the wrong colouring stems  from these changes:

-linewrap_length=72
-linewrap_quotation=1
-linewrap_pastes=1
+linewrap_length=80
+linewrap_quotation=0
+linewrap_pastes=0

The "-" lines are the good, pristine copy and the lines with the "+" are what I used to have. So one of them triggers the wrong colouring. With these changes reverted, I am still getting the long lines of the no-line-wrap which I'll investigate later on.

Regards,

-- Shlomi Fish
Comment 11 Pierre Fortin 2012-08-03 18:58:40 CEST
In case it helps, here's mine:
linewrap_length=74
linewrap_quotation=1
linewrap_pastes=1
linewrap_auto=1
Comment 12 Shlomi Fish 2012-09-14 13:34:13 CEST
Hi,

any progress? Do you need anything more from me?

Regards,

-- Shlomi Fish