Bug 2646 - Compile fails with gnutls-3.0.18
Summary: Compile fails with gnutls-3.0.18
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.8.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-04-07 21:41 CEST by Christian Hesse
Modified: 2012-05-16 07:47 CEST (History)
0 users

See Also:


Attachments
fix compile with gnutls-3.0.18 (400 bytes, patch)
2012-04-07 21:41 CEST, Christian Hesse
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Hesse 2012-04-07 21:41:20 CEST
Created attachment 1104 [details]
fix compile with gnutls-3.0.18

Compile fails when gnutls-3.0.18 is installed. The problem is that the data type gnutls_pkcs12_bag does no longer exist but was renamed to gnutls_pkcs12_bag_t. The patch is attached.

There are still a lot of deprecated warnings, though.
Comment 1 users 2012-05-16 07:44:34 CEST
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.claws-mail.org/tracker/

2012-05-16 [paul]	3.8.0cvs41

	* src/common/ssl_certificate.c
		fix bug 2646, 'Compile fails with gnutls-3.0.18'
		Patch by Christian Hesse