Bug 2630 - Draft sometimes not deleted when message sent
Summary: Draft sometimes not deleted when message sent
Status: RESOLVED WORKSFORME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 minor
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-03-15 13:25 UTC by J
Modified: 2012-09-13 20:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J 2012-03-15 13:25:34 UTC
Generally, when a message is sent, the draft is deleted. But sometimes, it is not.

It can happen even if I never saved the message while writing (in which case the draft is completely automatic).

It also happens that two drafts are recorded for the same message, which could be another bug or the same. I don't remember for sure that this already happened with automatic draft saving, though.
Comment 1 Paul 2012-06-04 06:21:09 UTC
is this IMAP?
Comment 2 Marcel van der Boom 2012-06-04 08:42:29 UTC
I see this behaviour occassionally too, and I am on IMAP
Comment 3 Paul 2012-06-04 09:06:59 UTC
probably/possibly a temporary network bottleneck. you could keep your drafts in a local MH folder.

See if --debug or the network can provide more information.
Comment 4 J 2012-06-04 13:04:11 UTC
IMAP indeed. I don't want to store drafts locally, as I also work on them from my webmail.

I'll try to use --debug. Something specific I should look for ?
Comment 5 J 2012-09-13 20:12:14 UTC
It still happens from times to times.

I just notice this in .xsession-errors :

/home/jerome/.claws-mail/imapcache/*domain*/*account*/Drafts/111597: unlink: Aucun fichier ou dossier de ce type

The draft that should have been erased is 

/home/jerome/.claws-mail/imapcache/*domain*/*account*/Drafts/111598

Don't know if this is useful.