Bug 2505 - tagsdb becomes polluted with old folder entries
Summary: tagsdb becomes polluted with old folder entries
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders (show other bugs)
Version: 3.7.10
Hardware: PC Linux
: P3 enhancement
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2011-09-21 15:26 CEST by Pierre Fortin
Modified: 2011-12-29 23:07 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Fortin 2011-09-21 15:26:57 CEST
Created a folder, renamed it and deleted it.
~/.claws-mail/tagsdb/<new_folder> gets created, then renamed; but when the folder is deleted, tagsdb does not reflect the deletion.

After more testing, the problem is more correctly stated as:

Test case #1:
create a new folder
rename it
delete it
no entry in tagsdb

Test case #2:
create a new folder
rename it
restart CM
tagsdb contains renamed folder

Test case #2:
create a new folder
restart CM
rename it
restart CM
tagsdb contains BOTH created-folder and renamed-folder

Anytime a folder is deleted, CM does not delete the tagsdb entry thereby allowing it to become more polluted over time.
Comment 1 users 2011-11-26 14:20:46 CET
Changes related to this bug have been committed.
Please check latest CVS and update the bug accordingly.
You can also get the patch from:
http://www.colino.net/claws-mail/

2011-11-26 [pawel]	3.7.10cvs105

	* src/folder.c
		Fix bug #2505 'tagsdb becomes polluted with old folder entries'