Bug 2499 - icon not entire in gnome shell
Summary: icon not entire in gnome shell
Status: RESOLVED PATCHESWELCOME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Notification (show other bugs)
Version: 3.7.10
Hardware: PC Linux
: P3 trivial
Assignee: users
URL:
: 2915 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-16 01:53 CEST by ppr
Modified: 2014-04-27 12:58 CEST (History)
3 users (show)

See Also:


Attachments
icon crop (1.11 KB, image/png)
2011-09-16 01:53 CEST, ppr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ppr 2011-09-16 01:53:37 CEST
Created attachment 1013 [details]
icon crop

With gnome 3 (gnome shell) the icon of the claws-mail notification plugin is some time crop (the envelope is not alway entire like in the screenshot attached).
Comment 1 ppr 2011-09-16 01:59:33 CEST
It's only a detail but God is in the detail...
Comment 2 Paul 2011-09-16 08:00:13 CEST
what about icons of other apps? is this a Claws bug or (perhaps more likely) a gnome3 bug??
Comment 3 ppr 2011-09-16 13:16:17 CEST
Thanks for your answer.

Claws-mail is the only program I use which has a icon crop. Maybe gnome 3 can't resize the enveloppe icon (format scalable, svg ?).
Comment 4 Ron 2013-04-30 18:32:47 CEST
In gnome-shell the system tray has a blank square where the claws mail icon should be. One has to mouse over it to see the place holder.  Any way to fix that?  Probably related to this bug.
Comment 5 Paul 2013-04-30 19:08:42 CEST
*** Bug 2915 has been marked as a duplicate of this bug. ***
Comment 6 Chad Wallace 2013-05-01 19:58:50 CEST
Using Gnome Shell 3.4.2 under Debian Wheezy, I see this behaviour with the icons of other programs as well (such as Liferea).

Also, if you reload the shell (by hitting Alt-F2 and typing r<Enter>) while the affected programs are open, they come back with full icons.

I'd say it's a Gnome Shell issue, but there may be a way to work around it.  I was going to suggest you look at how Audacious does their icon, because theirs is always full-size...  However, when I reload the shell, the Audacious icon disappears completely, so that's worse.  Best not to do what they do. ;-)
Comment 7 Michael Schwendt 2014-01-10 01:05:39 CET
Reported for Claws Mail 3.9.2 and GNOME Shell 3.10.2 on Fedora 20 (x86_64):
https://bugzilla.redhat.com/1051237

Reproducible with Claws Mail 3.9.3.

Initially, when loading and enabling the plugin, the icon appears. When restarting Claws Mail, the icon does not always disappear. When restarting GNOME Shell via Alt+F2 r<Enter>, the icon reappears.
Comment 8 Michael Schwendt 2014-01-10 12:41:27 CET
If I hardcode the tray icon (new_icon in src/plugins/notification/notification_trayicon.c) to a gdk_pixbuf_new_from_file(), it always displays that icon.

As soon as I replace that with a call to notification_pixbuf_get(), only an empty icon appears.

Somebody with deep insight into notification_pixbuf_get() could be helpful here.
Comment 9 Michael Schwendt 2014-01-10 12:52:24 CET
If I hardcode a gdk_pixbuf_new_from_file() in notification_pixbuf_get(), the icon appears always. When reverting to the calls to stock_pixbuf_gdk() (that's within Claws Mail core), an empty area is displayed instead.
Comment 10 Michael Schwendt 2014-01-10 17:02:07 CET
I think this is a bug in GNOME Shell, since what stock_pixbuf_gdk() does appears to be innocent. Scaling the tray related inline icon pixmaps rom 16x16 to 64x64, and the problem is not reproducible anymore. In Fedora bugzilla I also find several tickets about other programs that are affected.