Bug 2455 - perl plugin crash
Summary: perl plugin crash
Status: RESOLVED DUPLICATE of bug 2663
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins (show other bugs)
Version: 3.7.9
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2011-06-14 23:13 CEST by cvargas
Modified: 2012-08-18 20:48 CEST (History)
0 users

See Also:


Attachments
Debug of Claws-Mail (62.42 KB, text/plain)
2011-06-14 23:13 CEST, cvargas
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description cvargas 2011-06-14 23:13:51 CEST
Created attachment 989 [details]
Debug of Claws-Mail

Run claws-mail on Mandriva 2010.2 i586 with 1Gb RAM 
Output:
Claws Mail version 3.7.9
GTK+ version 2.20.1 / GLib 2.24.1
Locale: es_PE.UTF-8 (charset: UTF-8)
Features: IPv6 iconv compface GnuTLS LDAP JPilot GNU/aspell libetpan libSM
Operating system: Linux 2.6.36.2-desktop-2mnb (i686)
C Library: GNU libc 2.11.1
--
[Thread debugging using libthread_db enabled]
0xffffe424 in __kernel_vsyscall ()
#0  0xffffe424 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb6d5fc8b in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#2  0x080d6ee8 in ?? ()
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0xac05522c in Perl_pp_entersub ()
   from /usr/lib/perl5/5.10.1/i386-linux-thread-multi/CORE/libperl.so
No symbol table info available.
#5  0xac053530 in Perl_runops_standard ()
   from /usr/lib/perl5/5.10.1/i386-linux-thread-multi/CORE/libperl.so
No symbol table info available.
#6  0xabff5bf0 in Perl_call_sv ()
   from /usr/lib/perl5/5.10.1/i386-linux-thread-multi/CORE/libperl.so
No symbol table info available.
#7  0xabff8556 in Perl_call_pv ()
   from /usr/lib/perl5/5.10.1/i386-linux-thread-multi/CORE/libperl.so
No symbol table info available.
#8  0xabff862b in Perl_call_argv ()
   from /usr/lib/perl5/5.10.1/i386-linux-thread-multi/CORE/libperl.so
No symbol table info available.
#9  0xae7f0cd0 in perl_load_file () at perl_plugin.c:1433
        args = {0xae7f1fe3 "", 0xae7f20fc "0", 0x0}
        noargs = {0x0}
        perlfilter = <value optimized out>
        cmdline = <value optimized out>
        buf = 
    "\024\a\200\277\067\235&#1398;\000\000\000\000\333]\004\267Perl Plugin: filtering message...\000\000\000`\314\321\t\001\000\000\000\360\375Y\267\240\003\200\277p\003\200\277I\361&#438;X\003\200\277\004\063,\267`\314\321\t!\000\000\000\214\003\200\277\000\000\000\000<4\277\t\f\004\200\277\001\000\000\000\001\000\000\000\030#\334\t\360\"\334\t\260\363\006\267\274\214\302\t(\000\000\000\254\363\006\267\024\000\000\000\030\264\307\t \000\000\000`\210\067\n\250\003\200\277\234\004\200\277", '\000' <repeats 56 times>"\206, \277&#438;\370\340\347\t", '\000' <repeats 12 times>, " \017\005\267", '\000' <repeats 12 times>"\256, \311&#438;\000\000\000\000\000\000\000\000~\232&#438;\301\312&#1398;\364\257\002\267\000\234\\\n\330\343&#1334;\323}\002\267\001\000\000\000\264\a&#1270;n\000\000\000w\000\000\000\206\277&#438;[\000\000\000\071\000\000\000\t", '\000' <repeats 15 times>...
        n_a = <value optimized out>
#10 0xae7f17c0 in my_filtering_hook (source=0xbf801828, data=0x0)
    at perl_plugin.c:2031
        retry = <value optimized out>
        __PRETTY_FUNCTION__ = "my_filtering_hook"
#11 0x0824ca81 in ?? ()
No symbol table info available.
#12 0xb6f77806 in g_hook_list_marshal () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#13 0x0824cbd3 in hooks_invoke ()
No symbol table info available.
#14 0x081dfe27 in procmsg_msglist_filter ()
No symbol table info available.
#15 0x08128dd7 in ?? ()
No symbol table info available.
#16 0x08129e7f in inc_all_account_mail ()
No symbol table info available.
#17 0x0813c181 in ?? ()
No symbol table info available.
#18 0xb6f8546f in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#19 0xb6f84cbe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#20 0xb6f889f8 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#21 0xb6f88f07 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#22 0xb746aa19 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#23 0x0813f975 in main ()
No symbol table info available.
Kill the program being debugged? (y or n) [answered Y; input not from terminal]


Attached debug file of Claws Mail
Comment 1 Holger Berndt 2011-06-14 23:50:46 CEST
Can you reproduce it (e.g. with Tools -> Filter selected messages)? Can you attach a message that causes a crash?
Comment 2 cvargas 2011-06-15 03:50:36 CEST
When starting Claws-Mail is when crash occurs.
Comment 3 Holger Berndt 2012-08-18 20:48:55 CEST
It looks a lot like #2663. Please reopen if the fix doesn't solve it for you, or you can provide more information.

*** This bug has been marked as a duplicate of bug 2663 ***