Bug 1918 - add a search for contacts
: add a search for contacts
Status: RESOLVED FIXED
Product: Claws Mail
Classification: Unclassified
Component: UI/Address Book
: 3.7.1
: PC Linux
: P3 enhancement
Assigned To: users
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 13:24 CEST by ochosi
Modified: 2017-12-07 01:16 CET (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ochosi 2009-05-18 13:24:47 CEST
hi, i just quickly wanted to note that a search for the addressbook would be a really important feature. (it's quite funny that there is a "find duplicates" dialog but no "find" dialog :) )
at the moment when i'm looking for a contact/address i have to use the auto-completion in the compose-dialog.

it would also help if the address-list was key-sensitive (like if i mark some entry in the list and type a "k" and the list-focus jumps to entries starting with a "k").
Comment 1 P Fudd 2010-10-04 18:13:28 CEST
This is also something I really want: some way to search the address book.

Use case: I'm trying to send email to my father, but I can't remember his email address.  I just switched to claws-mail last month, and automatically harvested all of the email addresses from over 5 years worth of email.  Today I'm composing an email, then click to open the address book, but there's no 'search' button.  I have no way to find his address in the 20 or so address book folders that were created during the automatic harvest process.

Help?  Er, I mean, *feature request*!  :-)
Comment 2 Michael Rasmussen 2010-10-04 18:36:29 CEST
If LDAP doesn't scare you you could import all your addresses into LDAP. The LDAP address book has this nifty feature: Match names containing search term.

Combine that with TAB completion in the address fields in the message compose window and your are almost done.
Comment 3 codejodler 2010-10-05 03:14:13 CEST
That's a feature i would use more often, too. Especially since i use keywords (as comments) heavily, to remember what the addresses are for (there are way too many to remember by mind). Sometimes i need to find addresses where i only know the keyword. So, i really second that feature request.  

(I would be ok with a search for keywords 'anywhere' in the adress, name, or comment.)
Comment 4 ochosi 2010-10-05 10:34:24 CEST
iirc someone in #claws said that the addressbook codebase is in a very bad state and would have to be rewritten from scratch, but since it's none of the devs itches, nobody considers doing it. (seems that for many people the tab-completion in the compose window is sufficient.)

unfortunately i'm no good at coding, but maybe it's time for a community initiative?
Comment 5 Mike 2011-07-24 16:50:59 CEST
Lack of a search feature for the address book is the main limitation of Claws Mail.  The aliases also do not work optimally.  If an alias is created, it should supersede other autocomplete listings.
Comment 6 Paul 2013-01-22 11:21:01 CET
*** Bug 2864 has been marked as a duplicate of this bug. ***
Comment 7 users 2015-12-05 00:40:02 CET
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2015-12-05 00:40:02.237158556 +0100
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=a4c9d19459ecf1afaa1c314849c25fe2ef8d393c
Merge: c828ba6 ade3676
Author: Colin Leroy <colin@colino.net>
Date:   Sat Dec 5 00:40:01 2015 +0100

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=ade36765043da35dfac36ba905ff1b40efd88ead
Author: Charles Lehner <charles@claws-mail.org>
Date:   Fri Dec 4 17:51:16 2015 -0500

    Fix bug #1918: allow searching of local address books
    
    Based on code in Sylpheed by Hiroyuki from 2009-11-26
Comment 8 Ricardo Mones 2017-12-07 01:16:17 CET
Fixed 2 years ago...