Bug 4208 - Drafts are perceived as new mail
Summary: Drafts are perceived as new mail
Status: RESOLVED DUPLICATE of bug 3858
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Notification (show other bugs)
Version: 3.17.3
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2019-05-07 16:38 CEST by Denis
Modified: 2019-05-08 09:13 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2019-05-07 16:38:02 CEST
When I compose a new message, it is automatically saved in Drafts folder, and the whole time while I'm working on the letter, the tray icon looks as if there was new mail (though there isn't). When the message is sent, so the draft is no longer in the folder, the icon changes to the proper state (no new messages).
Comment 1 Pierre Fortin 2019-05-08 00:57:21 CEST
Not a bug.  See:
Configuration->Preferences->Plugins->Notification->SysTrayicon
Check "Only include selected folders" and click on Select folders...
Comment 2 Denis 2019-05-08 05:58:02 CEST
(In reply to comment #1)
> Not a bug.  See:
> Configuration->Preferences->Plugins->Notification->SysTrayicon
> Check "Only include selected folders" and click on Select folders...

Okay. But may be it is worth it to add an opposite option, "Exclude folders"?

First, many people auto-sort their incoming messages to several folders (I don't, but many people do), so it is simpler to exclude one folder, than to include several and to not forget to include an extra folder every time you create one.

Second, for me (and any RSSyl plugin user) this solution does not work at all. If I check "Only include selected folders", I can't select my folder with feeds: only mail folders are available for selection. So if I use this solution, the tray icon does not show when there are new feeds. Maybe "Exclude folders" would be better for this case?
Comment 3 Andrej Kacian 2019-05-08 08:01:30 CEST
Is this on a Google Mail account over IMAP?
Comment 4 Andrej Kacian 2019-05-08 08:03:42 CEST
(In reply to comment #3)
> Is this on a Google Mail account over IMAP?

Disregard this question, I was thinking of something else.
Comment 5 Paul 2019-05-08 09:13:21 CEST
This is essentially a duplicate of bug #3858. It may be a good idea to add your "Exclude folders" idea to that RFE.

*** This bug has been marked as a duplicate of bug 3858 ***