Bug 4139 - Clawsker broken in Archlinux
Summary: Clawsker broken in Archlinux
Status: RESOLVED INVALID
Alias: None
Product: clawsker
Classification: Unclassified
Component: default (show other bugs)
Version: GIT
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2018-12-21 18:18 CET by glitsj16
Modified: 2018-12-21 22:35 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description glitsj16 2018-12-21 18:18:27 CET
One of the recent commits in claws-mail adds a new hidden pref "use_tls_sni" [https://git.claws-mail.org/?p=claws.git;a=commit;h=01179f2c11f78a72f59bb606a6ba5f73c22a7c09]. When trying to set that I noticed clawsker is quite broken Arch Linux. Besides an issue caused by incorrect dependencies in the Arch Linux packaging of clawsker (easily fixed by rebuilding with the correct ones), the program refuses to start and throws a message about an uninitialized value (details below). Here's what I've done:

OS: Arch Linux (fully updated)

$ clawsker
Can't locate Gtk3.pm in @INC (you may need to install the Gtk3 module) (@INC contains: /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at /usr/bin/clawsker line 22.
BEGIN failed--compilation aborted at /usr/bin/clawsker line 22.

That's the packaging bug showing. Clawsker needs different dependencies than those currently stated in the official package [https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/clawsker]. I'll be filing an issue for that asap. Installing perl-gtk3 and try again:

$ sudo pacman -S perl-gtk3
...

$ clawsker
Can't locate File/Which.pm in @INC (you may need to install the File::Which module) (@INC contains: /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at /usr/bin/clawsker line 23.
BEGIN failed--compilation aborted at /usr/bin/clawsker line 23.

Another faulty dependency...

$ sudo pacman -S perl-file-which
...

$ clawsker
Use of uninitialized value $fver[2] in string eq at /usr/bin/clawsker line 298.
Invalid version string at /usr/bin/clawsker line 298.

I'm not at all experienced in Perl, but I'm getting the same error on Ubuntu, albeit on different lines of the script:

OS: Ubuntu 16.04 (fully updated)

$ apt-cache policy clawsker
clawsker:
  Installed: 0.7.13-1
  Candidate: 0.7.13-1
  Version table:
 *** 0.7.13-1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy perl
perl:
  Installed: 5.22.1-9ubuntu0.6
  Candidate: 5.22.1-9ubuntu0.6
  Version table:
 *** 5.22.1-9ubuntu0.6 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     5.22.1-9 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

$ clawsker
Use of uninitialized value $fver[2] in string eq at /usr/bin/clawsker line 260.
Invalid version string at /usr/bin/clawsker line 260.

Please note that I have very little experience with Perl, and it might be yet too soon to expect to see the newly added hidden pref "use_tls_sni", but clawsker seems broken with these perl versions. Don't have access to different perl versions currently, so the actual version number mentioned in this bug summary might not be fully correct. Please advise.

Regards
Comment 1 glitsj16 2018-12-21 18:41:31 CET
Follow-up: here's the packaging bug on Arch Linux
https://bugs.archlinux.org/task/61150
Comment 2 Ricardo Mones 2018-12-21 19:11:22 CET
We're not the packagers for Archlinux, not sure why did you open this bug.
Comment 3 glitsj16 2018-12-21 22:25:47 CET
Fully aware this isn't Arch Linux packaging bug tracker. I opened the clawsker bug report here because I honestly think that is where the aforementioned Perl issue lies:

$ clawsker
Use of uninitialized value $fver[2] in string eq at /usr/bin/clawsker line 260.
Invalid version string at /usr/bin/clawsker line 260.

That should have been the most important part. I admit that the presented context could be misleading, but I wanted to provide some context. And that context includes packaging issues (on Arch Linux only). Still, *after* fixing those issues (rebuilt clawsker from git with correct dependencies) I keep getting the same message as on a Ubuntu machine.
Comment 4 glitsj16 2018-12-21 22:35:47 CET
My sincere apologies. Something messed with my PATH. Twice, on both machines/OS'es. I stand corrected.

Regards.