Bug 3983 - Configure does not find "libical" and "libgdata" even the dev packages are installed.
Summary: Configure does not find "libical" and "libgdata" even the dev packages are in...
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.16.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2018-03-06 13:42 CET by Piotr
Modified: 2018-03-06 15:52 CET (History)
1 user (show)

See Also:


Attachments
./configure > configure.log (20.65 KB, text/x-log)
2018-03-06 13:42 CET, Piotr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr 2018-03-06 13:42:57 CET
Created attachment 1852 [details]
./configure > configure.log

Downloaded the source code of claws mail and ran ./configure, then installed libgdatta and libical. However the configure still complains about them. Here is the list of packages:

user@localhost:~$ sudo apt search libgdata | grep dev

libgdata-dev/oldstable,now 0.16.1-1 i386 [installed]


user@localhost:~$ sudo apt search libical | grep dev

libical-dev/oldstable,now 1.0-1.3 i386 [installed]

user@localhost:~/zzzz/claws-mail-3.16.0$ ./configure > configure.log
configure: WARNING: python-config not found. Maybe you need to install development packages for Python.
configure: WARNING: "Plugin gdata will not be built; missing libgdata "
configure: WARNING: "Plugin perl will not be built; missing libperl "
configure: WARNING: "Plugin python will not be built; missing python "
configure: WARNING: "Plugin vcalendar will not be built; missing libical "

Is it a bug or do I miss something?

Regards,
Piotr
Comment 1 Ricardo Mones 2018-03-06 15:52:10 CET
You need higher versions of those libraries, from configure.ac:

PKG_CHECK_MODULES(GDATA, libgdata >= 0.17.2, HAVE_GDATA=yes, HAVE_GDATA=no)

PKG_CHECK_MODULES(LIBICAL, libical >= 2.0, HAVE_LIBICAL=yes, HAVE_LIBICAL=no)