Bug 3940 - Depends on unmaintained pygtk
Summary: Depends on unmaintained pygtk
Status: RESOLVED LATER
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Python (show other bugs)
Version: 3.17.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL: https://bugs.debian.org/885266
Depends on:
Blocks:
 
Reported: 2017-12-26 14:10 CET by Ricardo Mones
Modified: 2018-01-02 14:27 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo Mones 2017-12-26 14:10:48 CET
Quoting original reporter:
,-------
| pygtk is unmaintained upstream. It has not had a release since GNOME 3
| was released in 2011.
| 
| The way forward is to port your app to use GObject Introspection
| bindings.
| 
| For more information on GObject Introspection see [1] and [2].
| 
| Please try to do this before the Buster release as we're going to 
| try to remove pygtk this cycle.
| 
| If you have any question don't hesitate to ask.
| 
| [1] https://wiki.gnome.org/Projects/GObjectIntrospection
| [2] https://wiki.gnome.org/Projects/PyGObject
`-------

FWIW no dates for Buster release (Debian 10) are already announced, but at current release rate that's probably happening around the middle of 2019 (see https://wiki.debian.org/DebianReleases for past dates).
Comment 1 Holger Berndt 2017-12-27 23:27:03 CET
GObjectIntrospection means using GTK+3. Calling GObjectIntrospection for GTK+2 "unmaintained" would be an under-statement - I think it's never been really supported. So I don't think anything can be done to improve the situation at this moment.

Btw, GTK+2 itself is also unmaintained and has had its last release in 2011. Shipping it in your distro but leaving out other basic parts leaves your packages in a somewhat rotten, degraded state.
Comment 2 Ricardo Mones 2018-01-02 14:27:13 CET
(In reply to comment #1)
> GObjectIntrospection means using GTK+3. Calling GObjectIntrospection for
> GTK+2 "unmaintained" would be an under-statement - I think it's never been
> really supported. So I don't think anything can be done to improve the
> situation at this moment.
> 
> Btw, GTK+2 itself is also unmaintained and has had its last release in 2011.
> Shipping it in your distro but leaving out other basic parts leaves your
> packages in a somewhat rotten, degraded state.

I agree with this last paragraph, notice the view of the distro is not the same for all developers ;-)

The problem is not the level of maintenance, of course.

If you cut a tree it makes a lot of noise, but if you prune branch by branch until the tree dies nobody will notice those branches falling. And in the end you will also have more reasons to cut it, since it has no branches to support.