Bug 3844 - Regression in 3.14: The acccount preference, 'Move deleted mails to trash and expunge immediately' has been removed.
Summary: Regression in 3.14: The acccount preference, 'Move deleted mails to trash and...
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders/IMAP (show other bugs)
Version: 3.14.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2017-07-04 14:17 CEST by Dianne Skoll
Modified: 2017-07-04 18:39 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dianne Skoll 2017-07-04 14:17:58 CEST
Hi,

Removal of the ability to work with the IMAP "deleted" flag as intended is a regression.  Moving messages to the Trash folder is not what I want.

The reason is that if you accidentally delete a message, moving it to Trash is lossy... it doesn't track the original folder.  Setting the Deleted flag is not lossy; you can restore the message exactly to its original state by clearing the flag.

Please revert this regression.

Regards,

Dianne.
Comment 1 Andrej Kacian 2017-07-04 14:36:47 CEST
Uncheck "Execute immediately when moving or deleting messages" in preferences, on Summaries page. You will get the desired behavior for both deleting and moving to trash.
Comment 2 Dianne Skoll 2017-07-04 15:01:33 CEST
I would like to reopen this.  Your solution works halfway, but Ctrl-E to
expunge deleted messages no longer works and I could not find a way to do it
from the menus.

Am I missing something else?

Regards,

Dianne.
Comment 3 Dianne Skoll 2017-07-04 15:04:28 CEST
Sorry, never mind.  I had customized my toolbar and the "Execute" button was missing.

It would be nice to have a keyboard shortcut for "Execute" if there isn't one.

Regards,

Dianne.
Comment 4 Ricardo Mones 2017-07-04 18:39:48 CEST
(In reply to comment #3)
> Sorry, never mind.  I had customized my toolbar and the "Execute" button was
> missing.
> 
> It would be nice to have a keyboard shortcut for "Execute" if there isn't
> one.

Already has one: see Tools/Execute menu option or the manual. You can also customize it.