Bug 3843 - Non-functional "Change to…" command in Spelling menu
Summary: Non-functional "Change to…" command in Spelling menu
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Compose Window/Spell Checker (show other bugs)
Version: 3.15.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2017-06-30 22:14 CEST by Tristan Miller
Modified: 2017-09-01 10:15 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2017-06-30 22:14:18 CEST
Deep in the Spelling pull-down menu of the compose window is a "Change to…" command that doesn't appear to do anything.  The ellipsis suggests that it is supposed to trigger a dialog window, but no dialog window appears.

Steps to reproduce:
1. Open the compose window
2. Spelling->Options->Dictionary: XX->Change to… (where XX is the name of the active dictionary)

Observed behaviour:
3. Nothing happens

Expected behaviour:
3. Presumably some sort of dialog window should appear.  (But what for, I have no idea.  I don't see any reference to this command in the Claws Mail User Manual.)
Comment 1 Andrej Kacian 2017-06-30 22:21:19 CEST
No, the "Change to..." is supposed to be sort of a title for the dictionaries submenu, giving context to what the choices below do. By itself, the menu item does not do anything.

In retrospect, perhaps it wasn't the best idea (I admit, it was mine). :)
Comment 2 Tristan Miller 2017-06-30 22:45:42 CEST
I think the menu would be understandable enough (and certainly less confusing) if the dummy command were simply removed.
Comment 3 Cristian Secară 2017-06-30 23:34:35 CEST
Somewhat related to this dialog group, the "Dictionary: XX" string has a weird alignment (looks like an uncentered middle).

I mention this in case the dialog will get some code review with the occasion of this bug report...
Comment 4 users 2017-07-01 11:41:03 CEST
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2017-07-01 11:41:03.055069454 +0200
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=8d068a4e44147abd01fd101f69beae58cefb7e53
Merge: 2d716b5 dc5de8c
Author: Colin Leroy <colin@colino.net>
Date:   Sat Jul 1 11:41:02 2017 +0200

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=dc5de8ca50faf4f9f4c456e3e6ba5887db05ccbc
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Sat Jul 1 11:39:06 2017 +0200

    Removed the "Change to..." fake menuitem from spelling dictionaries menu.
    
    Closes bug #3843: Non-functional "Change to…" command in Spelling menu