Bug 3803 - Can't send letters larger than 10kb via IMAP without SSL/TLS
Summary: Can't send letters larger than 10kb via IMAP without SSL/TLS
Status: RESOLVED DUPLICATE of bug 2262
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.15.0
Hardware: PC Windows 7
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2017-04-04 10:33 CEST by Timur
Modified: 2017-04-08 22:55 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2017-04-04 10:33:35 CEST
I'm using opensource mail server hmailserver and Claws Mail client connected via IMAP.
In case I do not use SSL / TLS, I encounter the following bug:
When I try to send a letter larger than ~10 kilobytes (no matter, with an attachment or just with a long text), Claws Mail gives me the following message:
 
Error: Could not queue message for sending.

Claws-Mail Network Log:
* Account 'accountname': Connecting to IMAP server: server.name:143...
[12:13:10] IMAP< * OK IMAPrev1 
* IMAP connection is un-authenticated
[12:13:11] IMAP> 1 CAPABILITY 
[12:13:11] IMAP< * CAPABILITY IMAP4 IMAP4rev1 CHILDREN IDLE QUOTA SORT ACL NAMESPACE RIGHTS=texk 
[12:13:11] IMAP< 1 OK CAPABILITY completed 
[12:13:11] IMAP> Logging accountname@domain.name to server.name using plaintext
[12:13:11] IMAP< LOGIN completed
[12:13:11] IMAP< Login to server.name successful
[12:13:11] IMAP> 3 LIST "" "" 
[12:13:11] IMAP< * LIST (\Noselect) "\\" "" 
[12:13:11] IMAP< 3 OK LIST completed 
[12:13:11] IMAP> 4 SELECT Queue 
[12:13:11] IMAP< * 0 EXISTS 
[12:13:11] IMAP< * 0 RECENT 
[12:13:11] IMAP< * FLAGS (\Deleted \Seen \Draft \Answered \Flagged) 
[12:13:11] IMAP< * OK [UIDVALIDITY 1489512006] current uidvalidity 
[12:13:11] IMAP< * OK [UIDNEXT 16] next uid 
[12:13:11] IMAP< * OK [PERMANENTFLAGS (\Deleted \Seen \Draft \Answered \Flagged)] limited 
[12:13:11] IMAP< 4 OK [READ-WRITE] SELECT completed 
[12:13:11] IMAP- [fetching UIDs...]
[12:13:11] IMAP> 5 UID FETCH 1:* (UID) 
[12:13:11] IMAP< 5 OK UID completed 
[12:13:11] IMAP> 6 APPEND Queue (\Seen) {29003} 
[12:13:11] IMAP< + Ready for literal data 
[12:13:11] IMAP> [data - 8166 bytes]
[12:13:11] IMAP> [data - 8190 bytes]
[12:13:11] IMAP> [data - 8190 bytes]
** IMAP error on server.name: stream error
** IMAP connection broken

hMailServer log:
"DEBUG"	3060	"2017-04-04 12:21:45.733"	"The read operation failed. Bytes transferred: 0 Remote IP: ip_address, Session: 252, Code: 2, Message: End of file"
"DEBUG"	3060	"2017-04-04 12:21:45.733"	"Ending session 252"

When I try to save a message as a draft, Claws Mail gives me the following message:

Error: could not save draft.
 
Network Log:
[12:23:03] IMAP> 6 APPEND Drafts (\Seen) {28938} 
[12:23:03] IMAP< + Ready for literal data 
[12:23:03] IMAP> [data - 8179 bytes]
[12:23:03] IMAP> [data - 8190 bytes]
[12:23:03] IMAP> [data - 8190 bytes]
** IMAP error on server.name: stream error
** IMAP connection broken

BUT! If I use SSL/TLS connection, the message is sent or saved as a draft without errors.
Comment 1 Andrej Kacian 2017-04-08 22:55:16 CEST

*** This bug has been marked as a duplicate of bug 2262 ***