Bug 3781 - Message causes segfault
Summary: Message causes segfault
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.15.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2017-03-08 16:31 CET by Pierre Fortin
Modified: 2017-03-10 10:01 CET (History)
0 users

See Also:


Attachments
debug log (13.58 KB, text/plain)
2017-03-08 16:31 CET, Pierre Fortin
no flags Details
messge which causes crash (59.72 KB, application/octet-stream)
2017-03-08 16:32 CET, Pierre Fortin
no flags Details
Complete --debug output when entering inbox via mouse click (14.22 KB, application/octet-stream)
2017-03-10 06:53 CET, Pierre Fortin
no flags Details
gdb bt full output (5.68 KB, text/plain)
2017-03-10 06:54 CET, Pierre Fortin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Fortin 2017-03-08 16:31:42 CET
Created attachment 1726 [details]
debug log

Claws Mail version 3.14.1git148

Haven't seen a crash in a very long time; but now, a message from auto parts company causes CM to crash. If I move the message away, no crash; move it back to inbox = crash.
Comment 1 Pierre Fortin 2017-03-08 16:32:12 CET
Created attachment 1727 [details]
messge which causes crash
Comment 2 Pierre Fortin 2017-03-10 06:53:47 CET
Created attachment 1728 [details]
Complete --debug output when entering inbox via mouse click

No changes to oxygen since July/2016.
All previous messages from this source are fine.
Updated to CM git 221
This message still crashes CM.
$ rpm -qa | grep oxygen
lib64oxygenstyleconfig4-4.11.16-5.mga5
kde4-style-oxygen-4.11.16-5.mga5
lib64qt5oxygenstyleconfig5-5.0.2-1.mga5
lib64oxygenstyle4-4.11.16-5.mga5
lib64oxygen-gtk3-1.4.1-3.mga5
lib64qt5oxygenstyle5-5.0.2-1.mga5
oxygen-icon-theme-4.14.3-3.mga5
lib64oxygen-gtk-1.4.6-2.mga5
oxygen-gtk-1.4.6-2.mga5
oxygen-gtk3-1.4.1-3.mga5
qt5-style-oxygen-5.0.2-1.mga5
icewm-theme-oxygen-aya-0.1-8.mga5

Yet...  when CM crashes, I see this msg 4 times:
** (cm:30899): WARNING **: /home/iurt/rpmbuild/BUILD/oxygen-gtk2-1.4.6/src/oxygenstylewrapper.cpp:3572: invalid icon size '16'

in which I see 2 issues:
1. /home/iurt is a) not on my system, b) not in claws source, c) IS in claws binary and plugins/*/*.so
2. oxygen-gtk2-1.4.6 does not match installed packages, unless gtk==gtk2

Last pixbuf update was in Oct/2016.

Decoded quoted-printable to normal html and it displays just fine in browser.
Created new message by removing quoted-printable and it still crashes the same way.

Running with gdb...
Comment 3 Pierre Fortin 2017-03-10 06:54:27 CET
Created attachment 1729 [details]
gdb bt full output
Comment 4 Andrej Kacian 2017-03-10 08:02:36 CET
Pierre, "iurt" was the username under which your Mageia packages were built on the packages builder's system, some of the paths to source files were hardcoded in packages' debug data. The bug is in the oxygen GTK2 theme. I can reproduce it as well, and it doesn't happen when I use a different theme.

From the GDB backtrace, it is clearly visible that the crash happens within GDK, as called from WebKit (possibly with some bogus parameters).

Notice how the only Claws Mail code involved is in the very first (lowermost) frame, in our main() function, as we call GTK's main event loop via gtk_main(). So, definitely not a bug within Claws Mail.
Comment 5 Pierre Fortin 2017-03-10 08:26:42 CET
Hi Andrej,

This is really strange...

I copied this message to another userid on same system. 
Same CM, same libs, same plugins, same preferences and it doesn't crash on that instance.

Copied *rc to the other userid and still no crash there...

I've always used the default theme.  Dumb Q; where do I find alternate CM themes? Tried some themes in /usr/share/themes; but they all error out with "This folder doesn't seem to be a theme folder.  Install anyway?"
Comment 6 Pierre Fortin 2017-03-10 08:46:33 CET
Installed Paul's clawsola and still crashes.
Comment 7 Andrej Kacian 2017-03-10 09:13:08 CET
This has nothing to do with Claws Mail icon themes, but rather GTK themes (or engines, as they call it), which control how all GTK applications look. The crash happens when using theme oxygen-gtk2. Try switching to another theme, e.g. Adwaita and see if the message still causes a crash.
Comment 8 Paul 2017-03-10 10:01:54 CET
Not a claws-mail bug, closing as INVALID.