Bug 3646 - SEGV when selecting unicode char ≥ U+10000 with fr_FR dictionary
Summary: SEGV when selecting unicode char ≥ U+10000 with fr_FR dictionary
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Compose Window/Spell Checker (show other bugs)
Version: 3.14.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2016-05-13 15:17 CEST by Jean-Benoist Leger
Modified: 2018-10-26 11:25 CEST (History)
0 users

See Also:


Attachments
call stack (6.42 KB, text/plain)
2016-05-13 15:17 CEST, Jean-Benoist Leger
no flags Details
Example to reproduce (in UTF-8) (29 bytes, text/plain)
2016-05-13 15:40 CEST, Jean-Benoist Leger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Benoist Leger 2016-05-13 15:17:20 CEST
Created attachment 1645 [details]
call stack

In the compose windows, I write text with unicode ≥ U+10000, like

> Hello
Comment 1 Jean-Benoist Leger 2016-05-13 15:28:33 CEST
It seems the bucktracker does not like ≥ U+10000 too.

So, I try again, without U+10000

In the compose windows, I write text with unicode ≥ U+10000, like (but with real caracter, not escaped one)

> Hello \U0001d500\U0001d4f8\U0001d4fb\U0001d4f5\U0001d4ed!

Without the bug
===============

I select text begining with a normal character e.g. (I use [] to mark selection):

> Hel[lo \U0001d500\U0001d4f8\U0001d4fb\U0001d4f5\U0001d4ed!]

and I right-click, nothing happens.

With the bug
============

I select text begining with a ≥ U+10000 character e.g. (I use [] to mark selection):

> Hello [\U0001d500\U0001d4f8\U0001d4fb\U0001d4f5\U0001d4ed!]

and I right-click, SEGV happens.

Details
=======

Version: bug happens with 3.11.1 packaged by my distribution and git version (commit c4ebc9dacb8242351b3cc485aadfe6bc05f89cd8)

Provided in attachment: gdb call stack for both version.
Comment 2 Paul 2016-05-13 15:32:13 CEST
looks like a crash in hunspell.
no crash here.
what dictionary are you using?
what distro and version are you using?
Comment 3 Paul 2016-05-13 15:33:52 CEST
Maybe you can attach a message which produces this? Or fwd as attachment to me directly.
Comment 4 Jean-Benoist Leger 2016-05-13 15:38:54 CEST
My distribution is Debian Jessie (8.4).

I use the `fr_FR` dictionnary. The problem does not happend wuth the `en`.

I will attach a message for reproducing.
Comment 5 Jean-Benoist Leger 2016-05-13 15:40:33 CEST
Created attachment 1646 [details]
Example to reproduce (in UTF-8)
Comment 6 Jean-Benoist Leger 2016-05-13 15:44:13 CEST
I think the bugtracker web interface hates me. Sorry for serverity change.
Comment 7 Paul 2016-05-13 16:34:31 CEST
It's not our bug. Probably hunspell's bug
Comment 8 Paul 2016-05-13 16:35:24 CEST
Sorry, didn't mean to close it. Not our bug, but not good to crash...
Comment 9 Paul 2018-10-26 11:25:11 CEST
presumably fixed in hunspell, no longer crashes here.