Bug 3642 - Character encioding automatic does not resolv iso-8859-1 encodings.
Summary: Character encioding automatic does not resolv iso-8859-1 encodings.
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Message View (show other bugs)
Version: 3.13.2
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2016-04-26 15:57 CEST by Erik P. Olsen
Modified: 2016-04-26 16:43 CEST (History)
0 users

See Also:


Attachments
e-mail with encoding that is incorrectly displayed (3.02 KB, text/plain)
2016-04-26 15:57 CEST, Erik P. Olsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik P. Olsen 2016-04-26 15:57:19 CEST
Created attachment 1643 [details]
e-mail with encoding that is incorrectly displayed

Summary says all. Please see attached e-mail in which special characters are incorrectly displayed as underscores.
Comment 1 Paul 2016-04-26 16:02:29 CEST
the html part has broken encoding. It is a broken message.
Comment 2 Paul 2016-04-26 16:04:58 CEST
More accurately. The html part is showing correctly. The underscores are really there. It's 8bit, as-is. So it was broken beforehand by whatever appended that html.
Comment 3 Erik P. Olsen 2016-04-26 16:35:02 CEST
(In reply to comment #2)
> More accurately. The html part is showing correctly. The underscores are
> really there. It's 8bit, as-is. So it was broken beforehand by whatever
> appended that html.

But if I change Character Encoding from automatic to iso-8859-1 the e-mail is displayed correctly. Since I don't use the fancy plugin I had expected the html part to be skipped.

As I see it the e-mail is not technically broken. The problem is that claws-mail displays the last part (text/html) rather than the first (text/plain). Is that normal behaviour even when fancy is not used?
Comment 4 Erik P. Olsen 2016-04-26 16:43:06 CEST
Sorry for the noise. I now see that I can select what is to be displayed of the two message parts. Clearly claws-mail performs correctly.