Bug 3519 - Links including umlauts are broken
Summary: Links including umlauts are broken
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Message View (show other bugs)
Version: 3.12.0
Hardware: PC Linux
: P3 minor
Assignee: users
URL:
: 3967 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-19 15:24 CEST by Ralf Mardorf
Modified: 2019-01-02 20:27 CET (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Mardorf 2015-09-19 15:24:20 CEST
Hi,

I noticed that links with umlauts are broken in Claws and FWIW in Evolution too.

For example: https://allestörungen.de/

Version 3.12.0.r43.g2780845

Regards,
Ralf
Comment 1 wwp 2015-09-19 21:12:07 CEST
I see similar issues with links in rssyl feeds.
Comment 2 Paul 2015-09-20 11:46:40 CEST

*** This bug has been marked as a duplicate of bug 1670 ***
Comment 3 users 2018-12-14 18:55:07 CET
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2018-12-14 18:55:07.281528611 +0100
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=74e46ecdb43be8fb8d79683426eed3b917f0430d
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Fri Dec 14 18:51:40 2018 +0100

    Added unit tests for get_uri_part().

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=476d7eca501ac7a5b367567297e028e89cc7e716
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Fri Dec 14 18:50:38 2018 +0100

    Make URI highlighting in textview and compose Unicode-aware.
    
    Fixes bug #3519: Links including umlauts are broken
Comment 4 Andrej Kacian 2018-12-14 19:08:39 CET
Better late than never, I guess. :)
Comment 5 Ralf Mardorf 2018-12-15 22:22:39 CET
Thank you, the issue is fixed.
Comment 6 Andrej Kacian 2019-01-02 20:27:18 CET
*** Bug 3967 has been marked as a duplicate of this bug. ***