Bug 3489 - Click on mailto link prepends http
Summary: Click on mailto link prepends http
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.11.1
Hardware: All Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-08-07 23:26 CEST by Technical Support
Modified: 2015-08-10 10:23 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Technical Support 2015-08-07 23:26:10 CEST
(3.11.1 - Latest version in Ubuntu repository)

Click on "mailto:" link prepends http:// to link and attempts to open in browser. Workaround is to switch to plain text view (instead of Fancy) to click on link - works as expected.
Comment 1 Salvatore De Paolis 2015-08-08 07:40:29 CEST
I cannot reproduce that. I guess it's a problem with your email. Can you attach it here or privately?
Thanks
Comment 2 Technical Support 2015-08-10 10:23:34 CEST
Fancy passes all links (including mailto: links) to an external browser. Non-Fancy (plain text) view automatically displays email addresses as links that it processes itself. This explains why part of claws worked and the other part didn't. The problem was with the browser, not claws.