Bug 3483 - When replying to a *de*crypted message, it is contained *encrypted* in reply
Summary: When replying to a *de*crypted message, it is contained *encrypted* in reply
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Privacy/PGP (show other bugs)
Version: 3.12.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 3517 3534 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-30 16:48 CEST by detlef.steuer
Modified: 2015-10-11 12:56 CEST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description detlef.steuer 2015-07-30 16:48:40 CEST
claws-mail 3.12.0 under Opensuse

Description: 
I receive a pgp-inline encrypted message. Enter passphrase and decrypt the
message. Works alright.

Hit reply.

Problem:
Editor window now contains encrypted version of original message, so a meaningful reply is impossible.

Workaround: Solved issue for the moment by downgrading to 3.10.1 .

My guess, because I use IMAP: It is related to your bugfix for decrypted messages in the draft folder on the imap server.

Nevertheless I think current beheaviour is worse than the old one.

Still, what I type is unencrypted in Draft, so it did not change too much to 
keep only the original message encrypted in the reply.
Comment 1 Paul 2015-07-30 17:23:58 CEST
Highlight the text that you want quote, then hit 'reply'.
Comment 2 detlef.steuer 2015-07-31 10:28:58 CEST
(In reply to comment #1)
> Highlight the text that you want quote, then hit 'reply'.

That breaks a 25 year old workflow how I handle "reply" in mails without a good cause. 

All I highlight for the reply is unencrypted on my imap server, just as before. If I do not trust my imap server I can not use "compose" or "reply" in my mail tool anyway. So that change in handling encrypted mails is worse than useless in my eyes. No real benefits, but new problems.  (If that behaviour really stems from a try to solve that problem with unencrypted drafts. I'm just a user ..)

Woudn´t a better solution of solving the original problem consist in a (configurable) local draft folder?

If the new behaviour has another reasoning I would like to understand it.

Detlef
Comment 3 Paul 2015-07-31 10:38:30 CEST
(In reply to comment #2)
> All I highlight for the reply is unencrypted on my imap server, just as
> before. 

No, it's not unencrypted on your imap server.

>  So that change in handling encrypted mails is worse
> than useless in my eyes.

There are benefits, if you don't see them then it's your eyes where the problem is.

> Woudn´t a better solution of solving the original problem consist in a
> (configurable) local draft folder?

That was and is already possible.
Comment 4 Paul 2015-07-31 10:43:44 CEST
It was the Tails team (or some of them) who kicked up the stink. https://tails.boum.org/security/claws_mail_leaks_plaintext_to_imap/index.en.html
And then didn't integrate the changes when they had the chance.
Comment 5 detlef.steuer 2015-07-31 11:44:27 CEST
(In reply to comment #3)
> (In reply to comment #2)
> > All I highlight for the reply is unencrypted on my imap server, just as
> > before. 
> 
> No, it's not unencrypted on your imap server.
> 
> >  So that change in handling encrypted mails is worse
> > than useless in my eyes.
> 
> There are benefits, if you don't see them then it's your eyes where the
> problem is.

Hmm. Using this mail client since it was called xfmail. Registered
bugzilla account just to (may be) help, because the new behaviour seems so very strange to me. 

I should have started with a big thank you to all the developers, that´s correct. I´m really grateful for claws-mail and all yoour work! 

But a little bit of friendly help to enlighten me on that topic would be very much appreciated, even if "the problem is in my eyes". 

I really would understand the reasoning, a link to some discussion 
on the list or something is enough. May be I can like it, if I understand the reason.

Detlef
Comment 6 Paul 2015-07-31 11:50:10 CEST
Claws Mail was never called xfmail! But thanks for at least part of your appreciation.
There is no discussion to point you to, because most of it was done on IRC.
But if you want to discuss it this is not the place, so try one of the places listed here instead:
http://www.claws-mail.org/MLs.php
Comment 7 users 2015-08-13 20:33:02 CEST
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2015-08-13 20:33:02.194477230 +0200
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=caa3406f32eea330a10e2108bbbff6ceb83e9dc6
Merge: 479d3cd 31806c2
Author: Colin Leroy <colin@colino.net>
Date:   Thu Aug 13 20:33:01 2015 +0200

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=31806c2352c74a2df322b3483b58123d9320e852
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Mon Aug 3 23:25:18 2015 +0200

    Improve how message body is quoted for reply/forward/etc.
    
    Insert body_start and body_end text marks around quotable
    message body, and quote that if user has not selected any text
    to quote for their reply.
    Closes bug #3483.
Comment 8 Andrej Kacian 2015-09-16 08:27:38 CEST
*** Bug 3517 has been marked as a duplicate of this bug. ***
Comment 9 Paul 2015-10-11 12:56:29 CEST
*** Bug 3534 has been marked as a duplicate of this bug. ***