Bug 3478 - Printing html rendered message makes printout use extra super small font
Summary: Printing html rendered message makes printout use extra super small font
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Fancy (show other bugs)
Version: 3.12.0
Hardware: PC Windows 7
: P3 trivial
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-07-26 16:12 CEST by daniel
Modified: 2015-07-27 16:29 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel 2015-07-26 16:12:52 CEST
With version 13.2. Claws, when messages are rendered using Fancy plugin, it no longer crashes on my Windoes 7 PC when I try to print message. Instead the printout uses extra small font. It is like font size 1 or maybe 0,1. 

I am aware of general attitude here towards Fancy plugin and HTML messages in general, but this is an error anyway which should be resolved in two possible ways:

(A) When printed, Fancy rendered appearance will be ignored and email will be printed in plain text in proper font size.

(B) When printed, Fancy rendered appearance will be preserved and proper font size will be used.
Comment 1 Andrej Kacian 2015-07-26 22:18:46 CEST
This seems to be a bug with WebkitGTK that happens with newer versions of GTK+:
https://bugs.webkit.org/show_bug.cgi?id=49502
https://bugs.webkit.org/show_bug.cgi?id=124226
https://bugs.webkit.org/show_bug.cgi?id=143563

It doesn't seem that Webkit developers have even acknowledged this bug yet, but good news is that the patch from bug 124226 works, and with it, the printing seems to be zoomed properly.

I will watch these Webkit bug reports to see what happens, but for now, I think the patch should suffice. Patched Webkit will be included in next Windows release of Claws Mail, hopefully sometimes next week.
Comment 2 daniel 2015-07-27 16:29:54 CEST
Ok, thank You. I had some crashes with claws and reportedly libgtk-win32-2.0-0.dll
should be guilty. So that probably might be the cause. will wait for new version than.