Bug 3466 - address auto-complete does not work on plasma5
Summary: address auto-complete does not work on plasma5
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI/Compose Window (show other bugs)
Version: 3.11.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 3470 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-13 12:44 CEST by Hiroshi
Modified: 2015-07-17 01:00 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hiroshi 2015-07-13 12:44:04 CEST
I recently upgraded to Kubuntu 15.04 with plasma5 desktop.
If I try to do auto-completing address on the compose window,  mouse cursor seems to brink but nothing appear.
If I switch to Unity environment on Kubuntu15.04, it works without problem.
So this issue is related to plasma5 desktop environment and claws-mail.
Comment 1 Paul 2015-07-14 09:44:59 CEST
There's one thing you can try:
* quit claws-mail
* open ~/.claws-mail/clawsrc in a text editor
* set address_search_wildcard=0

If this changes nothing then the bug is like your description implies - in plasma5.

Please report what you find when changing that hidden pref.
Comment 2 Hiroshi 2015-07-14 10:08:34 CEST
Thank you Paul,

I did what you suggested.
Nothing changed (once I saw the pop-up window appeared but I cannot reproduce it).
Sylpheed works auto-complete address even in plasma5 environment.
Comment 3 Paul 2015-07-15 20:59:46 CEST
*** Bug 3470 has been marked as a duplicate of this bug. ***
Comment 4 juergen_wille 2015-07-15 21:39:51 CEST
Since I'm the submitter of Bug 3470, I'd like to know whether you plan to work on this bug or let someone file a bug for plasma5?
Comment 5 users 2015-07-16 13:38:02 CEST
Changes related to this bug have been committed.
Please check latest Git and update the bug accordingly.
You can also get the patch from:
http://git.claws-mail.org/

++ ChangeLog	2015-07-16 13:38:02.050630952 +0200
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=69e4ed8282e94e2ccb0652e86d89d6aaf0f3a89d
Merge: 634546a 988ae8b
Author: Colin Leroy <colin@colino.net>
Date:   Thu Jul 16 13:38:01 2015 +0200

    Merge branch 'master' of file:///home/git/claws

http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=988ae8b83fbba2968b327a57baa148113ba69233
Author: Andrej Kacian <ticho@claws-mail.org>
Date:   Thu Jul 16 13:36:26 2015 +0200

    Fix address autocompletion popup not displaying on Plasma5.
    
    Closes bug #3466.
Comment 6 Andrej Kacian 2015-07-16 14:10:00 CEST
This will be fixed in an upcoming Claws Mail release. Thanks for the report!
Comment 7 juergen_wille 2015-07-16 22:34:22 CEST
I've tried to build the sources with the fix from git. The sources are lacking the configure - so I won't be able to ./configure and make.. The tarball with the claws-mail-3.11.1.tar.xz from sourceforge does include the configure script.
Comment 8 brad@fineby.me.uk 2015-07-16 22:42:58 CEST
GIT always lacks the .configure script.  Run autogen.sh then make
Comment 9 Hiroshi 2015-07-17 01:00:33 CEST
Thank you for your work to update claws-mail.
I compiled the claws-mail from the git repository and it works fine now on my Kubuntu 15.04.