Bug 3452 - Ability to register as default email program
Summary: Ability to register as default email program
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.12.0
Hardware: PC Windows 7
: P3 enhancement
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-06-28 20:33 CEST by daniel
Modified: 2015-10-15 12:36 CEST (History)
1 user (show)

See Also:


Attachments
Deafault programs (15.10 KB, image/jpeg)
2015-07-20 17:15 CEST, daniel
Details
claws01 default programs (49.86 KB, image/jpeg)
2015-07-20 17:16 CEST, daniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daniel 2015-06-28 20:33:09 CEST
I would like to be able to use Claws as default email program within the meaning of windows environment. Mainly in order to be able to use mailto: links to be opened by Claws.
Comment 1 Andrej Kacian 2015-06-28 21:17:36 CEST
The installer program asks you about this during installation. Does it not work when you answer Yes to the question?
Comment 2 daniel 2015-07-04 18:39:05 CEST
No, it does not.
Comment 3 daniel 2015-07-04 19:15:16 CEST
I just tried on win 8.1 with fresh install and it does not registers too.
Comment 4 Andrej Kacian 2015-07-04 19:25:26 CEST
You will have to wait for a new release (later this month), there will be some fixes for Windows registry entries needed for this functionality.
Comment 5 daniel 2015-07-20 17:15:08 CEST
With version 3.12. I tried couple of scenarios. association with mailto:example@example.com works just fine. windows (win7 in my case) can see claws in Default programs for mailto: protocol. But I cannot see it for Send  mail (see claws00 picture). But when I look to thunderbird settings, I see that option as assigned to Claws (see claws 01 picture). However Send mail option from Explorer or from PDF viewer does not work for me and ends with error that no default mail program is set.
Comment 6 daniel 2015-07-20 17:15:47 CEST
Created attachment 1542 [details]
Deafault programs
Comment 7 daniel 2015-07-20 17:16:20 CEST
Created attachment 1543 [details]
claws01 default programs
Comment 8 daniel 2015-07-22 14:25:13 CEST
Update: 
Click on send as email attachment does not work in Explorer or Foxit Reader. 
Click on send page link in email works in Firefox
Comment 9 Andrej Kacian 2015-07-22 15:30:53 CEST
Seems like this is caused by one extra registry key which we really shouldn't install, since Claws Mail doesn't support MAPI. I have removed it from the installer, next release will not set that key anymore.

To fix this, either take over the screenshotted functionality with application of your choice, or edit default value of following two keys using regedit:

HKEY_CURRENT_USER\SOFTWARE\Clients\Mail
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

I think we will also have to reword the default mail program question, because all Claws Mail really supports is the MAILTO protocol handling, not accepting e-mails via MAPI, which is what Explorer's "Send to recipient" apparently uses.
Comment 10 daniel 2015-07-23 09:43:25 CEST
Thank You Andrej. So as I understand it, mailto protocol works fine, mailMAPI is not and will not be supported. I understand it is out of the scope of interest of developers, but do You think that Claws is capable - when the settings in registry are set properly - to handle mailMAPI? Or is any experimenting just waste of time?
Comment 11 Andrej Kacian 2015-07-23 13:54:59 CEST
It should be possible, yes, if someone puts in the effort to figure out how exactly it works and how to implement it.

And although nobody on the team currently cares enough for this to make that effort, an eventual patch from someone else would most likely be accepted.
Comment 12 daniel 2015-10-12 00:01:34 CEST
Andrej, could this issue be left opened?
Comment 13 Andrej Kacian 2015-10-15 12:36:34 CEST
I'm not sure leaving it open will ever serve any purpose. See my comment #1 on http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2973