Bug 3411 - HTML content crashes Claws Mail
Summary: HTML content crashes Claws Mail
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.10.0
Hardware: PC Windows 7
: P3 major
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-03-24 21:18 CET by wazz
Modified: 2015-07-25 16:29 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wazz 2015-03-24 21:18:59 CET
Recently, my Claws has been crashing frequently on certain emails with some kind of content beyond plain text.  I have tried complete uninstalling and reinstall Claws.  I also tried Sylpheed, which seemed to be able to handle it.

In particular, I just received an email someone sent me from their iphone that caused Claws to crash. I was able to read the email via Roundcube webmail, and I used Roundcube to forward it to me, in parts. I narrowed down the issue to a a smiley face emoticon, which I have copy-pasted here -> 
Comment 1 Michael Schwendt 2015-03-26 00:19:39 CET
>  I narrowed down the issue to a a smiley face emoticon,
> which I have copy-pasted here -> 

Consider attaching the full email, i.e. including headers and body.
Comment 2 wazz 2015-03-26 01:48:52 CET
Return-path: <littlepiggyparlor@gmail.com>
Envelope-to: csr@pedipro.com
Delivery-date: Tue, 24 Mar 2015 11:45:17 -0700
Received: from mail-qg0-f48.google.com ([209.85.192.48]:34229)
	by panther.likeit.net with esmtps (TLSv1.2:AES128-GCM-SHA256:128)
	(Exim 4.85)
	(envelope-from <littlepiggyparlor@gmail.com>)
	id 1YaTp8-0002J2-Tm
	for csr@pedipro.com; Tue, 24 Mar 2015 11:45:11 -0700
Received: by qgep97 with SMTP id p97so3645707qge.1
        for <csr@pedipro.com>; Tue, 24 Mar 2015 11:45:08 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=from:content-type:content-transfer-encoding:mime-version:subject
         :message-id:date:references:in-reply-to:to;
        bh=svfuBCSMGhoAW62SKECSAGK/rs8fYh/OdnNiBzPlQmI=;
        b=u5aPvgKBRUWZmHh7jcLJDcqIKdXlNOJe8ZhTK108KTJ6/GFfdYi7jDUQhkEsoHXMGP
         zPT52Eabm6CwW5nAZM/8PItZq6U8kaFz1CUBcUunTswQ9TOPWVz3tfH/bjJcdbf0R86E
         F2E+gJuyaz9VEgIE3EELV7L/6mKm+ceno8ZU7zQLLvMKYSMscVmWd6JIVxLBK19gQIJG
         3tywMHPOcR+Dqkl5hcIh491UqYn1AtqDrUoLIQ+6NNbdQ5q+sSzQyZ8yK46xfp3Hy/3s
         oyqX34D9K7es75Wj2c/+p9v2CfPY64fouqwzl3FJgI3iodxmdsZO07W5XRg0a7GtG2ff
         IqTw==
X-Received: by 10.140.21.175 with SMTP id 44mr7378939qgl.78.1427222706751;
        Tue, 24 Mar 2015 11:45:06 -0700 (PDT)
Received: from [192.168.2.29] (cpe-071-070-253-000.nc.res.rr.com. [71.70.253.0])
        by mx.google.com with ESMTPSA id r136sm97179qha.0.2015.03.24.11.45.05
        for <csr@pedipro.com>
        (version=TLSv1 cipher=ECDHE-RSA-RC4-SHA bits=128/128);
        Tue, 24 Mar 2015 11:45:06 -0700 (PDT)
From: Dawn West <littlepiggyparlor@gmail.com>
Content-Type: text/plain;
	charset=utf-8
Content-Transfer-Encoding: quoted-printable
Mime-Version: 1.0 (1.0)
Subject: Re: Enquiry from PediPro.com
Message-Id: <8BD453C0-53E1-48AE-A36B-39E557923676@gmail.com>
Date: Tue, 24 Mar 2015 14:45:04 -0400
References: <E1YB6zs-0002j6-7P@panther.likeit.net> <20150113173643.00001934@pedipro.com> <CAMKh5DK_zk9UX6C3p8AS6DnrSaDoe=VCKGq9etkDvQ0T++HL9w@mail.gmail.com> <20150116093531.000006df@pedipro.com>
In-Reply-To: <20150116093531.000006df@pedipro.com>
To: "Customer Service @ PediPro.com" <csr@pedipro.com>
X-Mailer: iPhone Mail (12D508)
X--MailScanner-Information: Please contact the ISP for more information
X--MailScanner-ID: 1YaTp8-0002J2-Tm
X--MailScanner: Found to be clean
X--MailScanner-SpamCheck: not spam, SpamAssassin (not cached, score=-0.8,
	required 5, autolearn=not spam, DKIM_SIGNED 0.10, DKIM_VALID -0.10,
	DKIM_VALID_AU -0.10, FREEMAIL_FROM 0.00, RCVD_IN_DNSWL_LOW -0.70,
	RCVD_IN_MSPIKE_H2 -0.00, SPF_PASS -0.00, URIBL_BLOCKED 0.00)
X--MailScanner-From: littlepiggyparlor@gmail.com
X-Spam-Status: No

Thank you. I just placed an order on line today moments ago. Please throw in=
 an extra bag of COURSE pads. I appreciate your working with me. I'm hoping f=
or better results with this order =F0=9F=98=8A Dawn West

Sent from my iPhone
Comment 3 wazz 2015-03-26 01:50:09 CET
(In reply to comment #1)
> >  I narrowed down the issue to a a smiley face emoticon,
> > which I have copy-pasted here -> 
> 
> Consider attaching the full email, i.e. including headers and body.

Done
Comment 4 wazz 2015-04-20 16:05:11 CEST
This is continuing to happen, and it seems to be almost anything with HTML content.
Comment 5 wazz 2015-04-24 14:04:30 CEST
The crashing on HTML content occurs even if I am NOT viewing the email content.  Simply being in the mail list makes it crash.  I unloaded Fancy and get the same crash. Also tried reloading Fancy, and of course, uninstalling Claws and reinstalling.
Comment 6 Andrej Kacian 2015-07-25 16:29:00 CEST
I think this has been fixed in 3.12.0. Feel free to reopen if the problem persists.