Bug 3406 - "*** SSL handshake failed" by POP3-mailserver from STRATO.DE
Summary: "*** SSL handshake failed" by POP3-mailserver from STRATO.DE
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.10.1
Hardware: PC Windows XP
: P3 major
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-03-19 12:33 CET by Chris Ludwig
Modified: 2015-07-25 16:28 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Ludwig 2015-03-19 12:33:36 CET
Hi,

I use claws-mail in the last 6 months on an windows-pc (Claws-mail version 3.8.1 und now 3.10.1) and on an raspberri pi under rasbian (claws-mail version 3.8.1) as a test.

For 3 or 4 days I can't read mails from a POP3-server by the provider STRATO.DE, both on the windows-pc and on the raspi. The port used for POP3 is 995.

It's only the error message "*** SSL handshake failed".

Sending mails with claws-mail by the SMTP-server is OK.

Reading mails with claws-mail from the POP3-server by the provider T-ONLINE.DE make not problems.

My primary mail client is on my windows-pc a old eudora-installation. Under eudora all POP3-server (t-online and strato) works without problems. 

It's a problem from claws-mail for me.

How can I solve this problem?

Regards

Christoph Ludwig

(Please excuse my catastrophic english)
Comment 1 Andrej Kacian 2015-07-25 16:28:18 CEST
That is probably caused by the provider disabling SSLv3 (in response to POODLE vulnerability), and Claws Mail 3.10.1 not being able to handle it. This has been fixed in 3.12.0.

Feel free to reopen if the problem persists with 3.12.0.