Bug 3405 - Some folders no longer appear in the user interface (but are on disk)
Summary: Some folders no longer appear in the user interface (but are on disk)
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders/MH (show other bugs)
Version: 3.11.1
Hardware: PC Linux
: P3 major
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-03-19 10:43 CET by mark
Modified: 2015-03-19 11:05 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mark 2015-03-19 10:43:42 CET
A few of my subfolders no longer appear.
For example, I have this:

$ ls -h .email/Commercial/
10  11  12  13  14  15  16  17  18  2  3  4  5  6  7  8  9  Debenu  DiffPDF(c)  MyCommerce  Sales  Support

But today in the user interface I only have:

.email (MH)
    Inbox
    ...
    Commercial
        DiffPDF(c)

Whereas yesterday I had

.email (MH)
    Inbox
    ...
    Commercial
        Debenu
        DiffPDF(c)
        MyCommerce
        Sales
        Support

Claws knows that these folders are there: I tried creating Sales again and it refused.

For the time being I'm creating subfolders MyCommerce2 etc., but I wish claws would find the existing folders!
Comment 1 Paul 2015-03-19 10:46:02 CET
Right-click the top-level mailbox folder and choose 'Check for new folders' and/or 'Rebuild folder tree'.

If you can describe how this was triggered then re-open this with the description.
Comment 2 mark 2015-03-19 11:05:29 CET
Thank you for your quick reply: I did "Rebuild folder tree" as you suggested and it fixed the problem.