Bug 3395 - Notifications go crazy after importing an OPML RSS file
Summary: Notifications go crazy after importing an OPML RSS file
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/Notification (show other bugs)
Version: 3.11.1
Hardware: PC Linux
: P3 enhancement
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2015-03-04 00:27 CET by d33tah
Modified: 2015-03-07 11:32 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description d33tah 2015-03-04 00:27:17 CET
I just imported my RSS feeds from an OPML file and after seeing a lot of new folders with lots of new articles, Claws Mail went crazy, spamming me with popups telling me about these new findings.
Comment 1 Ricardo Mones 2015-03-04 00:34:41 CET
Notification plugin was just doing the work it's supposed to do.

If you plan to incorporate lots of new messages and don't want to be notified just disable notifications or unload the plugin temporarily.
Comment 2 d33tah 2015-03-04 12:23:12 CET
I still believe that this is definitely not a desired behavior. At the very least, IMHO the RSS plugin should disable the notifications during the import process.
Comment 3 Ricardo Mones 2015-03-04 12:58:35 CET
(In reply to comment #2)
> I still believe that this is definitely not a desired behavior. At the very
> least, IMHO the RSS plugin should disable the notifications during the
> import process.

The opposite belief is equally valid. Somebody could want to be notified of new messages during import to be sure the import is done correctly, specially if the number of messages is low or just because a less obtrusive notification method is being used.

Anyway AFAIK there's no API in the notification plugin to allow other plugins to fiddle with its settings, so for this you need this API first.
Comment 4 d33tah 2015-03-04 13:01:51 CET
Functionally, reporting of a succesful import is not a job of hundreds of popups. It's obvious that all these new articles would be unread and the notification for each of the folders is not that urgent. In my opinion, a single popup box (or even a dialog, as - again - it's not urgent) should be enough of a notification. The popup spamming basically renders the program unusable until the importing is done and affects general OS's GUI experience as we get a lot of popups in the screen's corner.
Comment 5 Holger Berndt 2015-03-07 11:32:59 CET
If you tell the Notification plugin to notify you of new messages in RSS folders, and new messages appear in RSS folders, it notifies you. This is correct and expected behaviour.

Notification flood prevention is a topic for the daemon.