Bug 3386 - Segmentation Fault when attempting to complete a name...
Summary: Segmentation Fault when attempting to complete a name...
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Plugins/GData (show other bugs)
Version: 3.11.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
: 3404 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-21 02:02 CET by lbickley
Modified: 2015-03-19 15:37 CET (History)
1 user (show)

See Also:


Attachments
Console output (817 bytes, text/plain)
2015-02-21 02:30 CET, lbickley
no flags Details
Output of: catchsegv claws-mail --debug > debug_claws_mail.txt (111.89 KB, application/gzip)
2015-02-21 17:29 CET, lbickley
no flags Details
output from gdb, etc. (91.95 KB, application/gzip)
2015-02-21 21:07 CET, lbickley
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lbickley 2015-02-21 02:02:47 CET
Running openSuse Linux: Linux asrock 3.16.6-2-desktop #1 SMP PREEMPT Mon Oct 20 13:47:22 UTC 2014 (feb42ea) x86_64 x86_64 x86_64 GNU/Linux
All updates are current.

Repeatable bug: I start composing - and in the To field enter the name "Jim" (quotes for clarity here only). I then hit a tab for completion - and immediately get a segmentation fault. The person I'm trying to contact is "Jim Schuetz" - who is defined in my gmail account. If I enter "Chuck" and tab - I can get the choice of "Chuck Schuetz" correctly (also Gmail).

Entering "Jim" fails everytime - always with a segmentation fault.
Comment 1 lbickley 2015-02-21 02:30:37 CET
Created attachment 1484 [details]
Console output
Comment 2 Salvatore De Paolis 2015-02-21 14:42:38 CET
You should attach the txt file you redirected the output to.
If you did that and this is the result, you need to install claws mail dev package and try again.
Comment 3 lbickley 2015-02-21 17:26:27 CET
Will attempt to upload the zipped results of:
catchsegv claws-mail --debug > debug_claws_mail.txt

Tried yesterday for over an hour to upload this 115K file - and got nothing but timeouts for over an hour.

BTW: PINGS to www.thewildbeast.co.uk have reasonable latency - so it seems specific to your website/Bugzilla. I can get to other websites "over the pond" w/o any timeouts....
Comment 4 lbickley 2015-02-21 17:29:18 CET
Created attachment 1485 [details]
Output of: catchsegv claws-mail --debug > debug_claws_mail.txt
Comment 5 lbickley 2015-02-21 17:31:07 CET
Well, the second - and most important attachment made it today w/o and  problems. A little slow - but O.K. :)
Comment 6 Salvatore De Paolis 2015-02-21 19:21:11 CET
Hi,
it seems it has something to do with templates, can you try following that [0] for debugging?

[0] http://www.claws-mail.org/faq/index.php/Debugging_Claws
Comment 7 lbickley 2015-02-21 21:07:16 CET
Created attachment 1486 [details]
output from gdb, etc.

Output from; gdb claws-mail > gdb_claws-mail.txt 2>&1

Claws-Mail compiled from sources with CFlag=-g
Comment 8 lbickley 2015-02-21 21:18:49 CET
I should have said:

Compiled from sources with CFLAGS=-g

Sorry
Comment 9 Holger Berndt 2015-03-15 19:24:09 CET
I was not able to reproduce the exact same crash, but a similar problem is now fixed in git. Please re-open if your crash is not fixed in current git.
Comment 10 lbickley 2015-03-15 19:36:08 CET
After a recent upgrading of clib and other libraries from openSUSE, this bug "disappeared". I have tested it for about three weeks - and no failures have re-occurred.

Looks like this bug may have been related to a library issue, outside the domain of Claws itself.

I will upgrade per current "git" in case this bug is merely "latent"...

Thanks, Lyle
Comment 11 Paul 2015-03-19 08:20:40 CET
*** Bug 3404 has been marked as a duplicate of this bug. ***
Comment 12 lbickley 2015-03-19 15:37:20 CET
Per your suggestion, I have been running with git download 3.11.1-79-gde6f18 ever since 3/17/15 and have experienced no seg. faults. Have used "Jim" and many other tab completions without any problems.