Bug 3059 - Wrong/Broken Keyboard Layout
Summary: Wrong/Broken Keyboard Layout
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.9.1
Hardware: PC Windows 7
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2014-01-13 19:06 CET by doria
Modified: 2014-01-14 13:51 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description doria 2014-01-13 19:06:13 CET
Hello,

i currently use the 3.9.1 gpg4win port. The "E", "F" and "B" keys don't output the corresponding Letters but instead act as:
E and F as "Enter"
B as "Return"

The problem only exists in the (whole subject,body etc.) composer window.

Keyboard Layout: "de_DE" (also tested en_US).

The same bug exists in 3.9.3 standalone version of "Claws Mail" (not gpg4win).

I am pretty sure that these keys worked as expected at start but now act as described above - a close reopen/restart does not solve the problem!


Plugins installed:
GtkHtml2-HTML-Viewer
PGP/Core
PGP/inline
S/MIME

I already tested uninstalling the html-view (didn't solve). The other plugins were installed when i first started the program so i don't think they produce the bug?

Hope you guys can help me as i really like the program! :)
Comment 1 Andrej Kacian 2014-01-13 20:26:04 CET
Just a thought - perhaps you inadvertently set those keys to some menu actions (it's easy with GTK, you just have to press a key while hovering over some menu). Try exiting claws-mail, moving "menurc" file away from configuration directory of claws-mail (I have no idea where that is on Windows), and starting claws-mail again to see if it fixes the issue.
Comment 2 doria 2014-01-14 11:10:57 CET
Awesome - Thanks!
Wasn't aware about this feature!

I had the following lines uncommented (as expected):
(gtk_accel_path "<Actions>/Menu/Edit/Advanced/EndLine" "e")
(gtk_accel_path "<Actions>/Menu/Edit/Advanced/BackChar" "b")
(gtk_accel_path "<Actions>/Menu/Edit/Advanced/ForwChar" "f")

I commented them instead deleting/moving the whole file. That solved it!
Guess i could empty the file if i don't want to use this feature?


For anyone else facing this problem (on Windows):
Make sure Claws Mail is closed or it will overwrite the menurc when closing.

The "menurc" file is located in "%userprofile%\AppData\Roaming\Claws-mail\".
This path (without the quotes) should work across all Windows versions since %userprofile% reflects the homepath.

Commented lines start with "; ". Uncommented lines (active commands) don't have the semicolon at start. Comment them or simply rename the file to menurc.bak.
That should fix the problem.


Tracker related:
You may should add RESOLVED > NOT A BUG or is RESOLVED > INVALID the equivalent?
Comment 3 Andrej Kacian 2014-01-14 13:51:37 CET
I'm glad the solution was this simple. :)

If you do not want to use customizable shortcuts at all, you can simply disable this feature in Claws-Mail preferences (on page Other -> Miscellaneous).

And yes, INVALID (or sometimes WORKSFORME) is our equivalent of NOTABUG.