Bug 3052 - Missing dll files/encryption errors
Summary: Missing dll files/encryption errors
Status: RESOLVED WORKSFORME
Alias: None
Product: Claws Mail (Windows)
Classification: Unclassified
Component: default (show other bugs)
Version: 3.9.3
Hardware: PC other
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2014-01-08 20:50 CET by doria
Modified: 2014-04-08 16:22 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description doria 2014-01-08 20:50:10 CET
Hi,

i've got several problems with the 3.9.3 build on windows.

Had before the gpg4win port used but noticed there was a newer version of Claws Mail.
I installed 3.9.3 on Windows 7 (you should add that to the OS list here) to the default dir (so both versions exist).

When starting 3.9.3 i get the following errors:
The following files are missing:
libintl-8.dll
libiconv-2.dll

I copied them from the gpg4win port and it started (seems like the install package got the above files missing).

After a successful start i get another error (in German):
--
Warnung

Die folgenden Plugins konnte nicht geladen werden. Prüfen Sie die Einstellungen des Plugins für mehr Informationen:

PGP/MIME
PGP/inline
S/MIME
--

(Could not load the above plugins - It suggests to check the configuration but there isn't much to configure under plugins) - btw. PGP works in the gpg4win port!

Also the spelling isn't correct in the message above - it should be:
"Die folgenden Plugins konnten nicht geladen werden." (missing n after konnte)

Another thing i wasn't aware of Claws installs GPA but i think it didn't even ask me if i want to? I already had Kleo installed :)
You may should ask for that (or did i miss that?)

greets
Comment 1 doria 2014-01-10 08:15:46 CET
The encryption plugin errors can probably be ignored it seems due to a incompatibility between the copied gpg4win dlls and what 3.9.3 requires (as i get now some errors when starting 3.9.3 stating the dlls are missing some functionality).

Hope that gets fixed soon! I would like to test 3.9.3 instead 3.9.1 :/
Comment 2 leprecon 2014-01-19 21:59:46 CET
If you installed Claws Mail 3.9.3 over GPG4WIN 2.2.1 with Claws Mail 3.9.1, do this:

1. Copy these files: libetpan-13.dll, libgcrypt-11.dll, libiconv-2.dll, libintl-8.dll from the directory Gnupg to the directory "Claws Mal". 

2. Run ...\GNU\Claws Mail\claws-mail.exe, remove and re-install modules pgpcore.dll, pgpmime.dll, pgpinline.dll. 

It will work.
Comment 3 doria 2014-01-20 14:12:19 CET
The errors are gone after copying the suggested files and re-installing the plugins.

For anyone else reading this:
When starting claws after copying the suggested files you will get one more error but after re-install of the plugin it should be fixed.

Its solved for me but i leave this as NEW because it still has to be fixed in install?
Comment 4 Colin Leroy 2014-01-20 21:28:26 CET
Hi,

Probably your Claws Mail preferences file references the GPG plugins from the GPG4Win install. Going to plugins, unloading all of them and reloading them from the Claws Mail directory should be enough to fix things cleanly.