Bug 2987 - Icons does not apperas
Summary: Icons does not apperas
Status: RESOLVED INVALID
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: UI (show other bugs)
Version: 3.9.2
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2013-08-07 15:24 CEST by Mirage42
Modified: 2013-08-21 10:05 CEST (History)
1 user (show)

See Also:


Attachments
Message pane when mime pane reduced to the right (11.88 KB, image/jpeg)
2013-08-07 15:24 CEST, Mirage42
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirage42 2013-08-07 15:24:54 CEST
Created attachment 1288 [details]
Message pane when mime pane reduced to the right

All icons have disappeared, even if I choose :

View -> Show or Hide -> Toolbar -> Text below/beside text

This becomes a matter since on the message pane, when I want to have the mime pane on the right, the message pane becomes all grey, making claws-mail unusable until I keep the mime pane on the top of the message pane.

Trying other themes gives me the same result.
Comment 1 Paul 2013-08-07 15:37:01 CEST
Tell us more about your system. There must be something particular about your system as this works and cannot be reproduced.
Comment 2 Mirage42 2013-08-07 15:57:21 CEST
This is a very common system.

uname -a
Linux FR-B-701-006 3.9-1-amd64 #1 SMP Debian 3.9.8-1 x86_64 GNU/Linux

cat /etc/debian_version 
jessie/sid

apt-cache policy claws-mail
claws-mail:
  Installed: 3.9.2-1
  Candidate: 3.9.2-1

What else would you need ?
Comment 3 Mirage42 2013-08-07 15:59:55 CEST
Here is an strace trace of claws-mail starting :

http://www.speedyshare.com/axvKG/claws.log
Comment 4 Mirage42 2013-08-07 16:01:32 CEST
Another link

http://www.sendspace.com/file/t5os9h
Comment 5 Paul 2013-08-07 16:07:47 CEST
Please don't re-set the importance/severity tag again. It's not 'major' because it seems isolated to your machine.
Comment 6 Paul 2013-08-07 16:27:15 CEST
(claws-mail:4045): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported

It seems that your libgdk-pixbuf2.0-0 installation is broken.
Comment 7 Mirage42 2013-08-07 16:33:54 CEST
libgdk-pixbuf2.0-0:
  Installed: 2.28.2-1
  Candidate: 2.28.2-1

already the latest version
Comment 8 Paul 2013-08-07 16:51:19 CEST
run `gdk-pixbuf-query-loaders | grep xpm`, you should see something like the following, perhaps with a different path to libpixbufloader-xpm.so.

"/usr/lib/ia64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-xpm.so"
"xpm" 4 "gdk-pixbuf" "The XPM image format" "LGPL"
"xpm" ""

If you see the above, then run `sudo gdk-pixbuf-query-loaders --update-cache`.

Then restart Claws and see if that's fixed the issue.
Comment 9 Michael Rasmussen 2013-08-07 16:56:36 CEST
Or maybe this library is missing: libgd2-xpm
Comment 10 Mirage42 2013-08-07 17:15:51 CEST
gdk-pixbuf-query-loaders is missing, can't find which package it is related to.

libgd2-xpm were missing. Installed, restarted claws-mail, didn't solve my problem.
Comment 11 Paul 2013-08-07 17:35:34 CEST
gdk-pixbuf-query-loaders is in libgdk-pixbuf2.0-dev
Comment 12 Andrej Kacian 2013-08-07 17:44:55 CEST
It is also in /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/, installed by main libgdk-pixbuf2.0-0 package.
Comment 13 Mirage42 2013-08-21 09:29:56 CEST
Sorry for the delay...

Paul's solution was the best. It works now