Bug 2971 - SIGSEGV while sending mail in offline mode
Summary: SIGSEGV while sending mail in offline mode
Status: RESOLVED DUPLICATE of bug 2769
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders/IMAP (show other bugs)
Version: other
Hardware: PC Windows XP
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2013-07-13 23:55 CEST by kardan
Modified: 2013-07-14 10:54 CEST (History)
0 users

See Also:


Attachments
gdb trace (35.75 KB, text/plain)
2013-07-13 23:55 CEST, kardan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kardan 2013-07-13 23:55:07 CEST
Created attachment 1283 [details]
gdb trace

1. compose and send mail
2. switch to offline mode while sending

** (claws-mail:2221): WARNING **: [23:35:49] IMAP4-Verbindung unterbrochen
(claws-mail:2221): Claws-Mail-WARNING **: can't append message /home/kardan/.claws-mail/tmp/queue.0x9e2050071392297
(claws-mail:2221): Claws-Mail-WARNING **: can't queue the message

Program received signal SIGSEGV, Segmentation fault.
0xb6dd17d9 in _int_malloc (av=av@entry=0xb6f06440 <main_arena>, bytes=bytes@entry=2560) at malloc.c:3621
Comment 1 Michael Schwendt 2013-07-14 06:37:25 CEST
That's bug 2769 (also https://bugzilla.redhat.com/569478 ) but some other forms of losing networking (not clicking the "offline mode" button) can also crash Claws Mail when using IMAP.
Comment 2 Paul 2013-07-14 10:54:23 CEST

*** This bug has been marked as a duplicate of bug 2769 ***