Bug 2956 - crash while reading rss folders: gtkcmctree.c:3900 Condition node != NULL failed
Summary: crash while reading rss folders: gtkcmctree.c:3900 Condition node != NULL failed
Status: RESOLVED WORKSFORME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders (show other bugs)
Version: 3.9.3
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2013-07-04 16:05 CEST by kardan
Modified: 2013-07-15 11:53 CEST (History)
0 users

See Also:


Attachments
claws --debug + gdb 7.6 trace (3.75 KB, application/octet-stream)
2013-07-04 16:05 CEST, kardan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description kardan 2013-07-04 16:05:15 CEST
Created attachment 1281 [details]
claws --debug + gdb 7.6 trace

Claws hit again, this time into my drive. It crashed while reading my rss folders.
Note: In the previous session I move one folder which failed because of insufficient disk space.

summaryview.c:2992:TIMING summary_sort : 0s276ms
summaryview.c:3219:TIMING summary_set_ctree_from_list bold_unread: 0s000ms
summaryview.c:3224:TIMING summary_set_ctree_from_list : 1s088ms
gtkcmctree.c:3900 Condition node != NULL failed
traceback:
0:      /usr/bin/claws-mail(gtk_cmctree_select+0x187) [0x828742f]
1:      /usr/bin/claws-mail() [0x80e0bce]
2:      /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x13ba61) [0xb7c4ba61]
3:      /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_closure_invoke+0x186) [0xb74fbc56]
4:      /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(+0x1fed7) [0xb750ded7]
5:      /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0xecb) [0xb75160db]
6:      /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_signal_emit_by_name+0x485) [0xb7516745]
7:      /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x29036e) [0xb7da036e]
8:      /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x290c49) [0xb7da0c49]
9:      /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(gtk_main_do_event+0x494) [0xb7c46d84]
10:     /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0(+0x579b8) [0xb7ab89b8]
11:     /lib/i386-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x143) [0xb7435353]
12:     /lib/i386-linux-gnu/libglib-2.0.so.0(+0x486f0) [0xb74356f0]
13:     /lib/i386-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x41) [0xb74357d1]
14:     /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(gtk_main_iteration+0x31) [0xb7c45b91]
15:     /usr/bin/claws-mail(summary_select_node+0x1ab) [0x81ca25f]
16:     /usr/bin/claws-mail(summary_show+0x14db) [0x81c7e27]
17:     /usr/bin/claws-mail() [0x80de90e]
18:     /usr/bin/claws-mail(claws_marshal_VOID__POINTER_INT+0xb2) [0x82c8b88]
19:     /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_closure_invoke+0x186) [0xb74fbc56]
20:     /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(+0x1fed7) [0xb750ded7]
21:     /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0xecb) [0xb75160db]
22:     /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x33) [0xb75162b3]
23:     /usr/bin/claws-mail(gtk_cmctree_select+0x25c) [0x8287504]
24:     /usr/bin/claws-mail() [0x8281eab]
25:     /usr/bin/claws-mail() [0x82acfed]
26:     /usr/bin/claws-mail(gtk_cmclist_unselect_all+0x14c) [0x829bc67]
27:     /usr/bin/claws-mail() [0x82ab9a7]
28:     /usr/bin/claws-mail() [0x82ac48f]
29:     /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x138722) [0xb7c48722]
Comment 1 Paul 2013-07-15 09:36:47 CEST
this doesn't seem to have anything at all to do with RSS, looks like an imap thing.

If you can reproduce this then re-open it with detailed steps of how to reproduce it.
Comment 2 kardan 2013-07-15 11:53:39 CEST
This happened during startup reading the rss tree.

The way to reproduce this:
1. Open Claws
2. Fill up your disk
3. Move RSS folders
4. Claws will crash
5. Start claws
6. Claws will crash again (due to empty feeds.xml)

Both crashes should not happen, but claws may check if there is sufficient disk space before it opens a config file for writing.

From the trace it is visible (?) that there was no UI interaction but claws crashed on startup filling the folder tree after loading RSS feeds.

#4  0x080de90e in folderview_selected (ctree=0x8556208, row=0x88ef720, column=-1, folderview=0x8645958) at folderview.c:22148
#32 0x080fe33a in main (argc=1, argv=0xbffff5c4) at main.c:1547
        gtk_main();