Bug 2911 - Mails got deleted when my internet connection dropped while moving them
Summary: Mails got deleted when my internet connection dropped while moving them
Status: RESOLVED WORKSFORME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders/IMAP (show other bugs)
Version: 3.9.1
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2013-04-22 16:38 CEST by Richard Schwab
Modified: 2013-06-10 09:05 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Schwab 2013-04-22 16:38:54 CEST
Hey there,

I'm using 3.9.0.187.g9c84307 and IMAP4.

Today I had the following problem:

I'm using an UMTS mobile internet connection.
I selected a few mails in Claws-Mail and told it to move them to some different folder, while I was doing that my connection dropped.
When I reconnected it it just deleted the messages, without realizing that they weren't copied previously, resulting in me loosing some mails.

--
Sincerely
Richard Schwab
Comment 1 Richard Schwab 2013-04-22 18:33:24 CEST
The mail was moved inside one IMAP account from one folder to another.
Comment 2 Paul 2013-04-23 12:53:58 CEST
Cannot reproduce this.

I killed the connection during the move operation on a large file. When I resumed the connection the file was still in the original folder, but now has a 'message is marked for move' icon in the S (status) column.

Can you reproduce your problem?
Comment 3 Paul 2013-04-23 12:55:50 CEST
I meant 'message' not 'file', of course.
Comment 4 Paul 2013-06-10 08:53:07 CEST
no response
Comment 5 Richard Schwab 2013-06-10 09:05:13 CEST
Sorry, forgot to reply. No, I cannot reproduce :/