Bug 2899 - Claws Mail crashes after fetching messages from the "All mail" folder in GMail
Summary: Claws Mail crashes after fetching messages from the "All mail" folder in GMail
Status: RESOLVED WORKSFORME
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Folders/IMAP (show other bugs)
Version: 3.9.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2013-04-03 13:34 CEST by m.keyran
Modified: 2015-02-23 15:04 CET (History)
1 user (show)

See Also:


Attachments
Log of the valgrind (323.88 KB, application/x-bzip)
2013-04-03 13:34 CEST, m.keyran
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.keyran 2013-04-03 13:34:35 CEST
Created attachment 1250 [details]
Log of the valgrind

Claws Mail crashes with SEGFAULT after trying to get the contents of the "All Mail" folder from gmail.

There is last lines from gdb:

summaryview.c:3097:     Setting summary from message data...
procmsg.c:301:TIMING procmsg_get_thread_tree thread by subject: 0s006ms
procmsg.c:311:TIMING procmsg_get_thread_tree : 0s048ms
summaryview.c:3138:TIMING summary_set_ctree_from_list threaded: 0s149ms
summaryview.c:3185:done.
summaryview.c:3188:     msgid hash table size = 8662
summaryview.c:3191:     subject hash table size = 0
summaryview.c:2960:Sorting summary...
Program received signal SIGSEGV, Segmentation fault.
0x0000000000682f0b in gtk_cmctree_post_recursive (ctree=<error reading variable: Cannot access memory at address 0x7fffff7fe2a8>, node=<error reading variable: Cannot access memory at address 0x7fffff7fe2a0>, 
    func=<error reading variable: Cannot access memory at address 0x7fffff7fe298>, data=<error reading variable: Cannot access memory at address 0x7fffff7fe290>) at gtkcmctree.c:3304
Comment 1 Paul 2013-04-07 14:04:23 CEST
Does this happen every time? Re-open if it does.
Comment 2 m.keyran 2013-04-07 16:41:33 CEST
Yes, it does. Claws mail works perfectly well on my 32-bit netbook, but it always crashes on my 64-bit workstation. Tried to launch it from another user, the same effect.
Comment 3 Paul 2013-04-23 14:35:20 CEST
What else is different between your 2 systems? I've tried it on both 32bit and 64bit systems and both work fine for me.
Comment 4 Bogdan 2015-02-23 15:03:56 CET
In 3.11 on a 64 bit Linux platform crashes every time.

I have 8 IMAP accounts and one folder (MH) where I move some of the messages through filter rules.

Claws mail crashes when clicking on a folder with unread messages. It takes a lot of time do do whatever it does and ends up crashing almost every time. 

The message on the bottom bar is "Setting summary from message data" and the cursor keeps rotating until the whole thing crashes.

It mostly crashes on folders from the MH created repository and on sub-folders folders in a IMAP structure such as the GMAIL labelled folders.

Please do not close the bug before checking all these options. On simple INBOX folders seems to be fine. Most likely the problem is on sub-folders and special MH folders

For me is unusable at this stage. It used to work fine before upgrading to 3.11