Bug 2814 - Virtual Folders based on search criteria
Summary: Virtual Folders based on search criteria
Status: RESOLVED DUPLICATE of bug 2250
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Other (show other bugs)
Version: 3.9.1
Hardware: PC All
: P3 enhancement
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-11-20 22:07 CET by Abhay S. Kushwaha
Modified: 2012-11-20 22:53 CET (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abhay S. Kushwaha 2012-11-20 22:07:17 CET
Claws could support Virtual Folders which would display the emails that match the search criteria defined in the virtual folder property.

One way is to add a checkbox in folder creation dialog box that creates a virtual folder anywhere. When enabled, the dialog would also include a search bar (much like the quicksearch bar) that will help users create the rule to show emails in that folder. I don't see a need for virtual folders in the middle of the folder tree but this is one way it can be done.

The more interesting way is to have a folder called, say "Views" just below the main 5 folders (Inbox, sent, etc.) which would allow people to add virtual folders with the search criteria.

The folder's search could be "global" (all messages in the mailbox) or targeted (specific folder only, with and without sub-folder recursion).

The folder would only display message headers from the target folders. So they're essentially "links" to the actual mails in the specific folders. But it would still allow mail operations (Move to Trash actually does).

The folders would be constantly updated with a fast refresh cycle (1s?)

Here is a sample scenario to illustrate use:
Say a person has 3-4 folders for different projects where project-specific support emails get filtered to. Virtual folders would allow this person to quickly find emails that have not been replied to which are older than 1 day, rather than performing a recursive quicksearch, moving to each folder, etc. So if this person suddenly sees that there is 1 email in this virtual folder, he knows a response is delayed by 24 hours and he can quickly find and reply to that specific email.

That's a very straightforward example for illustration only. I'm sure everybody will be able to quickly come up sample scenarios where it could be helpful to their individual needs.
Comment 1 Paul 2012-11-20 22:53:39 CET

*** This bug has been marked as a duplicate of bug 2250 ***