Bug 2764 - Complete lockup during filter edit
Summary: Complete lockup during filter edit
Status: RESOLVED FIXED
Alias: None
Product: Claws Mail
Classification: Unclassified
Component: Filtering (show other bugs)
Version: 3.8.0
Hardware: PC Linux
: P3 normal
Assignee: users
URL:
Depends on:
Blocks:
 
Reported: 2012-10-24 15:18 CEST by Jim Smith
Modified: 2012-11-24 10:11 CET (History)
0 users

See Also:


Attachments
screen shot of initial config screen (106.87 KB, image/png)
2012-10-24 15:18 CEST, Jim Smith
no flags Details
Screenshot showing lockup when simply trying to add a folder. (363.09 KB, image/png)
2012-10-24 15:21 CEST, Jim Smith
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Smith 2012-10-24 15:18:01 CEST
Created attachment 1174 [details]
screen shot of initial config screen

Claws Mail 3.8.0  Ubuntu 12.04.1 Desktop
Claws Mail extraordinarily aggravating error sequence.

Ubuntu Desktop 12.04.1 recent install


Claws Mail opens normally 
Configuration>Filtering   : opens ok

Filtering configuration - form
typein Name  ok
click in action then click on define button ok
select move select folder ok
click in Condition ok
click define ok
click match criteria select header select name "From" ok
pasted in address ok
clicked Add  ok
Now the Name, Account, Condition, and Action fields are all complete ok.
Now click Add (filter) ok (it shows up in the list of filters)

Now starting the process over without leaving the Filtering configuration form.

Typein new name for this next filter ok
clicked action>Define button ok
clicked Action Button select Move ok (move is the default anyway but I select anyway) ok
click in Desination click Select button ok
Select Folder form is open ok
Click on New ok
New Folder Form opens ok
click in Input the name of new folder form field and cannot type  
cannot even see the mouse cursor inside the form at all after the initial click.
click back onto desktop and then back on any of the five claws mail window and
the Input new folder form is highlighted, but mouse is not avaiable, and keyboard
input does not work, either, even though all visual indications show that the form
is ready for input from the keyboard.
cannot type into form
cannot cancel
cannot click ok
cannot click x to close that form
cannot close any of the five claws mail windows
the only way out I've found is to logout.

This does not happen every time, but almost always the first
time or the second time.

Almost every time the problem occurs it is in the Action Form.
Move is the default, but if you click on it, and it's going to hang up, you get nothing when clicking.  Clicking on any other portion of the form does nothing.
Clicking in any of the other 4 windows open does nothing.

This would not be nearly as aggravating if you could just close Claws Mail and restart it, but the only recovery that seems to work is doing a user logout and login.  Then start Claws Mail.

Best Regards, 
Jim
Comment 1 Jim Smith 2012-10-24 15:21:30 CEST
Created attachment 1175 [details]
Screenshot showing lockup when simply trying to add a folder.

I had forgotten to add this info into the bug report, but when trying to select folder for moving message, if you try to add a new folder, it almost always locks up.  This is especially aggravating because most of the time you've already done all of the work for the filter except this part, but you cannot save work in progress.
Comment 2 Paul 2012-10-24 15:33:47 CEST
probably the same as bug #2758
can you try it with the latest release?
https://launchpad.net/~claws-mail/+archive/ppa

What GTK+ theme do you use?
What desktop?
Comment 3 Jim Smith 2012-10-24 18:26:41 CEST
System Information
GTK+ 2.24.10 / GLib 2.32.3
Locale: en_US.UTF-8 (charset: UTF-8)
Operating System: Linux 3.2.0-32-generic (x86_64)
Comment 4 Jim Smith 2012-10-24 18:29:18 CEST
Yes, I also remember having that same issue when trying to delete accounts on my last installation.

Here's my system info from the claws mail help>about screen
System Information
GTK+ 2.24.10 / GLib 2.32.3
Locale: en_US.UTF-8 (charset: UTF-8)
Operating System: Linux 3.2.0-32-generic (x86_64)
Comment 5 Paul 2012-10-24 18:41:06 CEST
Jim,
Which desktop do you use?
Comment 6 Jim Smith 2012-10-24 22:54:17 CEST
[Jim,
Which desktop do you use?]

I am guessing you mean ?  
It is not KDE, so I'm assuming you mean Gnome
I have not tweaked my default install of 12.04.1
I only changed the screen background.
I guess it is called Unity.  Isn't that info in my last post
about the system info from Claws?
Here it is again.
System Information
GTK+ 2.24.10 / GLib 2.32.3
Locale: en_US.UTF-8 (charset: UTF-8)
Operating System: Linux 3.2.0-32-generic (x86_64
Comment 7 Jim Smith 2012-10-24 22:57:28 CEST
Additional info

If I bring up the Configuring Filters window and DO ALL manual editing without ever selecting any Browse or Select Button, I never have any problems.

I've discovered that the best workaround is to right click a filter that is similar, and duplicate several filters, then I manually edit them with the correct info, and then simply replace the duplicated filter.  This works fine, I've just finished doing 3, one right after the other, and never had a single hiccup.

Jim...
Comment 8 Paul 2012-11-24 10:11:35 CET
should be fixed in 3.9.0 - re-open if you can still replicate this